Issue Details (XML | Word | Printable)

Key: CORE-3532
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Alexander Peshkov
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Server hangs starting new session when trace is running

Created: 21/Jun/11 09:00 AM   Updated: 23/Apr/13 01:01 PM
Component/s: Engine
Affects Version/s: 3.0 Initial, 2.5.0
Fix Version/s: 2.5.1, 3.0 Alpha 1

Time Tracking:
Not Specified

Environment: posix

Planning Status: Unspecified


 Description  « Hide
This issue may seem to duplicate CORE-3512, but it's caused by absolutely other reason.
3512 was caused by not changed trace file number, this one - by an attempt to lock shared mutex recursively.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 21/Jun/11 09:07 AM
Added emulation of recursive mutex in trace manager.