Issue Details (XML | Word | Printable)

Key: CORE-3596
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Adriano dos Santos Fernandes
Reporter: Dmitry Yemanov
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Client library cannot connect to the non-ASCII host name

Created: 13/Sep/11 04:07 AM   Updated: 24/Nov/17 11:15 AM
Component/s: API / Client Library
Affects Version/s: 2.5.0
Fix Version/s: 3.0 Alpha 1, 2.5.8

File Attachments: 1. Text File interface.patch (1 kB)


QA Status: Cannot be tested


 Description  « Hide
Since v2.5.0 the connection string is converted into UTF8 in the Y-valve, prior to calling the providers that are expected to convert it back into the system charset if required. But it doesn't happen for the host name in the remote provider (interface.cpp) causing the connection attempt to fail.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Dmitry Yemanov added a comment - 05/Dec/11 12:39 PM
A simple patch that seems to fix the issue is attached, but I'm not sure it's correct for the all possible cases.

Adriano dos Santos Fernandes added a comment - 05/Dec/11 01:50 PM
I don't see a problem, but unfortunately I currently have no prepared Windows environment to build and test Firebird.

Dimitry Sibiryakov added a comment - 21/Dec/11 04:53 PM
A problem will definitely appear if system charset doesn't include all required symbols. I don't know if unicode version of gethostbyname exists...

Dmitry Yemanov added a comment - 21/Dec/11 05:05 PM
Dimitry, provided that system->UTF8->system transformation is peformed on the same host (in fbclient), how could it be possible?

Paolo Salvan added a comment - 11/Jul/17 01:41 PM
We are using FB 2.5.7 and a lot of our software users are having connection problem because their server has non-ascii characters in the name.

Will this patch be backported to FB 2.5.8?

Dmitry Yemanov added a comment - 13/Jul/17 06:59 PM
Paolo, I will check what was actually committed into v3.0 and plan a backport, if it appears possible.

Dmitry Yemanov added a comment - 24/Nov/17 11:15 AM
Backported to v2.5.8.