Issue Details (XML | Word | Printable)

Key: CORE-3675
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Dmitry Yemanov
Reporter: Edson Teixeira Marques
Votes: 1
Watchers: 6
Operations

If you were logged in you would be able to see more operations.
Firebird Core

CREATE INDEX considers NULL and empty string being the same in compound indices

Created: 24/Nov/11 06:21 PM   Updated: 23/Apr/13 01:26 PM
Component/s: Engine
Affects Version/s: 2.5.1
Fix Version/s: 2.5.2

Time Tracking:
Not Specified

Environment: windows 2008 and seven, debian, ubuntu desktop oneiric
Issue Links:
Duplicate
 
Relate
 

Planning Status: Unspecified


 Description  « Hide
The situation is as follows:
A table has an alternate key constraint (unique). The expression of key is composed of four distinct fields of the table. In two rows from the table, the field of order 2 (in the expression of key), has the following "values" (in quotes because is "null" is not value):null and ''(empty) respectively. That is, in the record 'n' the field is set to null, in the record n​​+1 the same field have the value''(empty). The other values ​​of the other fields components of the alternate key in these records have values ​​equal to each other. As illustrated below:

TABLE1
FIELD_A, FIELD_B, ..., FIELD_1 | FIELD_2 | FIELD_3 | FIELD_4, ..., FIELD_n
-------------------------------------------------- -----------------------------------------------
...
any, any, ..., any | any | any | any, ..., any
any, any, ..., x | null | y | z, ..., any
any, any, ..., x | | y | z, ..., any
any, any, ..., any | any | any | any, ..., any
...
-------------------------------------------------- -----------------------------------------------
('any': any values​​, different from each other. x, y and z can be any value, but equals in the two rows)

What happens is that when I recover a ".fbk" of this database, gbak can not activate the alternate key index coposed by FIELD_1, FIELD_2, FIELD_3 and FIELD_4, because it believes there may be a violation of the unique key constraint, however, if the TABLE1 does not have any records (no data), gbak, obviously, can recover the database and enable the constraint and, in this situation, I can insert all these records with all these values ​​(that gbak couldn't recover previously), and there's no unique key violation.
This issue has been identified in firebird 2.5.1. We tested the same database in firebird 2.5.0 and this problem did not happen.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order

Dmitry Yemanov added a comment - 29/Nov/11 01:44 PM
No, they look different (at least CORE-3610).

Dmitry Yemanov added a comment - 29/Nov/11 01:52 PM
Looks like a regression introduced by CORE-2709.