Issue Details (XML | Word | Printable)

Key: CORE-3724
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Alexander Peshkov
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Server hangs when working with events

Created: 11/Jan/12 09:51 AM   Updated: 23/Apr/13 01:32 PM
Component/s: Engine
Affects Version/s: 2.1.4
Fix Version/s: 2.1.5

Time Tracking:
Not Specified

Environment: posix

Planning Status: Unspecified


 Description  « Hide
Server hangs when working with events.
Was reproduced using fbtcs events-related tests.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 11/Jan/12 11:49 AM
The reason of races was checking internals of shared object rem_port twice - inside select_port() function and after it's invocation. Avoid such behavior by partially backporting logic from 2.5 & trunk.