Issue Details (XML | Word | Printable)

Key: CORE-3733
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Ramsees Rastafa
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

GBAK fails to fix system generators while restoring

Created: 16/Jan/12 09:19 PM   Updated: 23/Apr/13 01:35 PM
Component/s: GBAK
Affects Version/s: 2.5.1
Fix Version/s: 2.1.5, 2.5.2, 3.0 Alpha 1

Time Tracking:
Not Specified

File Attachments: 1. File rastrometa.fbk (226 kB)

Environment:
Windows 7, Windows Server 2003
Firebird 2.5.1
Intel i3 CPU

Planning Status: Unspecified


 Description  « Hide
I have a .fbk file that cannot be restored using fb 2.5.1, I have no problems with fb 2.5.0, the error I get is:

gbak: committing metadata
Database restore canceled 14:17:15 due to IBPP exception:

*** IBPP::SQLException ***
Context: ServiceImpl::Wait
Message: isc_service_query failed

SQL Message : -413
Overflow occurred during data type conversion.

Engine Code : 335544334
Engine Message :
conversion error from string "1O1 "

This is the FlameRobin error, but I get the same error if I use gbak in the console.

I can send you the .fbk if you ask me, since I don't see a way to attach it here.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Ramsees Rastafa added a comment - 16/Jan/12 09:20 PM
Here is the fbk.

Dmitry Yemanov added a comment - 17/Jan/12 05:34 AM - edited
Recreate the primary key on the table DRASCLIENTES before backing up and the restore will succeed. I don't know how you managed to create it as it looks like being named by the engine itself but in fact it was named manually using the reserved prefix (INTEG_). This situation confuses some part of the restore code.

Dmitry Yemanov added a comment - 17/Jan/12 05:38 AM
Alex, this is a regression caused by the fix for CORE-3461. I would suggest to ignore (all or conversion only) errors while fixing the generators.

Alexander Peshkov added a comment - 18/Jan/12 12:06 PM
Use correct way to detect digital strings. In 2.1 with missing SIMILAR TO had to ignore errors when fixing generators.