Issue Details (XML | Word | Printable)

Key: CORE-374
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Nickolay Samofatov
Reporter: css
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Restore with SPs in 'COMPUTED BY' fields fails

Created: 15/Oct/04 12:00 AM   Updated: 03/Feb/11 09:50 AM
Component/s: GBAK
Affects Version/s: None
Fix Version/s: 2.1 RC1

Time Tracking:
Not Specified

Issue Links:
Duplicate
 
Relate
 

SF_ID: 1047576


 Description  « Hide
SFID: 1047576#
Submitted By: css

A restore fails on a table that has computed fields
which select a value from a stored procedure, eg.
....computed by ( Select Total from
StoredProc_Total(table.PK) )
will cause a prerviously backedup database not to be
restored correctly.
ErrorMessage: "Unsuccessful execution caused by system
error that does not preclude successful execution of
subsequent statements.
action cancelled by trigger (0) to preserve data integrity.
could not find table/procedure for GRANT."

The table is granted the right to execute/reference the
StoredProcedure.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
peter worbis added a comment - 22/Feb/07 03:53 PM
the restore also fails if you are using an udf in a computed by field