Issue Details (XML | Word | Printable)

Key: CORE-3911
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Alexander Peshkov
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

API entrypoints Bopen and BLOB_open are not visible

Created: 29/Aug/12 11:33 AM   Updated: 23/Apr/13 02:01 PM
Component/s: API / Client Library
Affects Version/s: 2.5.0, 2.5.1
Fix Version/s: 2.5.2

Time Tracking:
Not Specified

Environment: MacOSX

Planning Status: Unspecified


 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Dmitry Yemanov added a comment - 29/Aug/12 11:59 AM
What about the rest?

BLOB_close
BLOB_display
BLOB_dump
BLOB_edit
BLOB_get
BLOB_load
BLOB_put
BLOB_text_dump
BLOB_text_load

They were always public in Windows.

Alexander Peshkov added a comment - 29/Aug/12 12:31 PM
The rest are OK.
The problem is that API_ROUTINE macro for Mac is defined in a way that only single lexem may be opresent before it, i.e.

typedef char* pchar;
pchar API_ROUTINE bla-la-la....

is OK, but

char* API_ROUTINE bla-la-la....

gives a warning and doesn not export symbol. Looking better I've found that both 2.1 and trunk already had fixes for it. Now I change name of typedef to better one from trunk and close an issue.

Alexander Peshkov added a comment - 29/Aug/12 12:41 PM
Backported solution from trunk