Issue Details (XML | Word | Printable)

Key: CORE-4028
Type: Bug Bug
Status: Open Open
Priority: Major Major
Assignee: Unassigned
Reporter: PizzaProgram Ltd.
Votes: 1
Watchers: 2

If you were logged in you would be able to see more operations.
Firebird Core

aliases.conf # reading error

Created: 04/Jan/13 04:16 AM   Updated: 05/Jan/13 03:13 AM
Component/s: Documentation, Engine, GBAK, GFIX, Installation, Security
Affects Version/s: 2.1.0, 2.1.1, 2.0.5, 2.1.2, 2.1.3, 3.0 Initial, 2.0.6, 2.5.0, 2.1.4, 2.5.1, 2.0.7, 2.1.5, 2.5.2, 3.0 Alpha 1, 2.1.6, 2.5.3, 3.0 Beta 1, 3.0 RC2
Fix Version/s: None

Environment: ALL (Windows, Linux)

 Description  « Hide
Firebird can not connect to any database defined in "aliases.conf" if file or folder name contains # char.
 Example : myalias = C:\#MyFirstFolder\MyDatabase.FDB

- There is no mention in the aliases.conf file's comment section about that (should be like at firebird.conf)
- It is a common practice to change folder or filenames beginning with # or _ signs to place them to first in the list

The Solution would be, if there would be a "# disabling sign" like: @
 and the engine or any other utilities (like gbak, gfix) would recognize this and ignore any # signs in that line beginning with that
 Example: @myAlias = C:\#MyFirstFolder\MyDatabase.FDB

Thanks !

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Michal Kubeček added a comment - 04/Jan/13 07:52 AM
You can use double quotes to avoid interpreting the hash sign, e.g.

myalias = "C:\#MyFirstFolder\MyDatabase.FDB"

This works for aliases.conf in 2.5 and for all config files in 3.0.

On the other hand, documenting this feature on top of firebird.conf (in 3.0) would be a good idea. I'll prepare a commit.

PizzaProgram Ltd. added a comment - 05/Jan/13 03:13 AM
I would recommend documenting directly in [aliases.conf] file (not in [firebird.conf] only).
And please include same [comment] section about " # " in [aliases.conf] at older installers too !
 <OFF> took me 4 hours to figure out, why engine is showing "I/O error" message only because I'm starting to use alias instead of direct path on some mashines. More confusing was that same program with same database with same engine worked fine on other mashines... </OFF>

Thanks for the "Double quotes" tip! But sadly I'm still using the 2.1.5 engine, and did not help there.
 (I've tried before posted this issue) :(

<OFF> I guess I won't be able to delay any longer to rewrite my program to work with 2.5 but it's difficult </OFF>