Issue Details (XML | Word | Printable)

Key: CORE-4139
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Dmitry Yemanov
Reporter: Dmitry Yemanov
Votes: 1
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Error "invalid stream" can be raised in some cases while matching a computed index

Created: 04/Jul/13 08:00 AM   Updated: 10/Jul/15 08:43 PM
Component/s: Engine
Affects Version/s: 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.5.0, 2.1.4, 2.5.1, 2.1.5, 2.5.2, 2.1.5 Update 1, 2.5.2 Update 1
Fix Version/s: 2.5.3

QA Status: Done successfully
Test Details:
Confirmed fail on WI-V2.5.2.26540:
Statement failed, SQLSTATE = HY000
bad BLR -- invalid stream


 Description  « Hide
Test case:

create table A (ID int);
create table B (ID int);
create index IDX on A computed by (ID);

select min( (select 1 from A where cast(ID as int) = B.ID) ) from B
-- ERROR: bad BLR -- invalid stream.

This error is not present if computed index is not created or if CAST is omitted inside the query.


 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Dzirt added a comment - 08/Jul/13 05:33 AM
After this fix does not work this:

recreate table G ( ID Integer, OBJECT_ID computed by (ID) );
commit;
insert into G( OBJECT_ID ) values( 1 );

with message

This column cannot be updated because it is derived from an SQL function or expression.
attempted update of read-only column.

Dmitry Yemanov added a comment - 08/Jul/13 07:44 AM
It's the result of CORE-3874, not this one.