Issue Details (XML | Word | Printable)

Key: CORE-4210
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Adriano dos Santos Fernandes
Reporter: Vladimir Arkhipov
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Preserve comments for output parameters after altering procedures

Created: 06/Sep/13 12:07 PM   Updated: 25/Sep/15 01:08 PM
Component/s: None
Affects Version/s: 2.5.1, 2.5.2, 2.5.2 Update 1
Fix Version/s: 2.5.3

Issue Links:
Relate
 

QA Status: Done successfully
Test Details: Confirmed for 2.5.0...2.5.2: lost comments for some arguments.


 Description  « Hide
–°ontinuation of CORE-3140. After fixing does not work for output parameters. For input parameters description is preserved.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Adriano dos Santos Fernandes added a comment - 06/Sep/13 02:53 PM
Cannot reproduce:

SQL> create or alter procedure p1 (i integer) returns (o integer) as begin end;
SQL> comment on parameter p1.i is 'input';
SQL> comment on parameter p1.o is 'output';
SQL> show comments;
COMMENT ON PARAMETER P1.I IS input;
COMMENT ON PARAMETER P1.O IS output;
SQL> alter procedure p1 (i integer) returns (o integer) as begin end;
SQL> show comments;
COMMENT ON PARAMETER P1.I IS input;
COMMENT ON PARAMETER P1.O IS output;

Vladimir Arkhipov added a comment - 06/Sep/13 03:19 PM
The problem is reproduced when I use domains or type of column for parameters.
Comments for parameters with simple types (like integer) is preserved.

Adriano dos Santos Fernandes added a comment - 06/Sep/13 03:23 PM
What I see is this, when an input parameter is changed to output, the comment is lost:

SQL> alter procedure p1 (o integer) returns (i integer) as begin end;
SQL> show comments;
COMMENT ON PARAMETER P1.O IS output;

Adriano dos Santos Fernandes added a comment - 06/Sep/13 03:40 PM
I found problem in 2.5, but are you sure there is still problem in v3-alpha1?

If yes, please send a valid test case.

Vladimir Arkhipov added a comment - 06/Sep/13 03:52 PM
Sorry, I did not test it again on Firebird 3.0 Alpha 1, remove this version from issue.
But on Firebird 2.5 the problem is reproduced when I use domains or type of column for parameters.

Adriano dos Santos Fernandes added a comment - 06/Sep/13 03:58 PM
Please test the fix in the next 2.5 snapshot build.

Vladimir Arkhipov added a comment - 10/Sep/13 08:29 AM
Works fine, thank you.