Issue Details (XML | Word | Printable)

Key: CORE-4286
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Paulius Pazera
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

"Statement already has a cursor assigned" error when trying to execute another SQL statement using different cursor name

Created: 03/Dec/13 09:29 AM   Updated: 26/Dec/15 02:54 PM
Component/s: None
Affects Version/s: 3.0 Alpha 1, 3.0 Alpha 2
Fix Version/s: 3.0 Beta 1

Environment:
64-bit server fb30alpha1 (30761) classic on sles11 sp3, 32-bit fbclient.dll on winXPpro, IBObjects 5.2.0.6 (delphi XE2)


QA Status: Cannot be tested
Test Details:
Could not reproduce with python driver.

BTW, there is _no_ method 'clear_cache()' for Cursor object, despite on document reference that can be found here:

http://www.firebirdsql.org/file/documentation/drivers_documentation/python/fdb/reference.html#cursor


 Description  « Hide
our application uses IBObjects, and it did not work with fb3. It was giving "Statement already has a cursor
<cursorName> assigned". We are using the same TIB_Cursor object to execute different SQL statements. First statement is executed ok,
second gives the error (showing cursor name from first execution). I checked IBObjects code and found that during unprepare they
clear cursor name, and during prepare, if cursor name is empty then it generates random value. After I modified IBObjects unprepare
code not to clear previous cursor name (as a work around) then it started to work with fb3


 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov made changes - 03/Dec/13 10:41 AM
Field Original Value New Value
Assignee Alexander Peshkov [ alexpeshkoff ]
Alexander Peshkov added a comment - 10/Dec/13 01:52 PM
Paulius, I want to know what client version did you use.
Ideally I also need an exact sequence of API calls cause I can't experiment with Delphi IBO.

Alexander Peshkov made changes - 17/Jan/14 12:35 PM
Status Open [ 1 ] Resolved [ 5 ]
Fix Version/s 3.0 Beta 1 [ 10332 ]
Resolution Fixed [ 1 ]
Alexander Peshkov made changes - 17/Jan/14 12:36 PM
Affects Version/s 3.0 Alpha 2 [ 10560 ]
Pavel Cisar made changes - 22/Sep/15 09:38 AM
Status Resolved [ 5 ] Closed [ 6 ]
Pavel Zotov made changes - 26/Dec/15 02:54 PM
Status Closed [ 6 ] Closed [ 6 ]
Test Details Could not reproduce with python driver.

BTW, there is _no_ method 'clear_cache()' for Cursor object, despite on document reference that can be found here:

http://www.firebirdsql.org/file/documentation/drivers_documentation/python/fdb/reference.html#cursor
QA Status Cannot be tested