Issue Details (XML | Word | Printable)

Key: CORE-4417
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Adriano dos Santos Fernandes
Reporter: Oliver Wurdak
Votes: 0
Watchers: 4
Operations

If you were logged in you would be able to see more operations.
Firebird Core

gbak: cannot commit index ; primary key with german umlaut

Created: 02/May/14 07:18 PM   Updated: 25/Sep/15 01:11 PM
Component/s: GBAK
Affects Version/s: 2.5.2 Update 1
Fix Version/s: 2.5.3, 3.0 Beta 1

Environment: Windows7 64 Bit; firebird 64 Bit
Issue Links:
Relate
 

QA Status: Done successfully
Test Details:
Confirmed crash of restoring on WI-V2.5.2.26540: message about abnnormal program termination appeared.
No any troubles on 2.5.3 and above, including 3.0.


 Description  « Hide
I create a database with the following isql script. (CreateErrorDB.sql)
in the reduced table (1 field ,1 record) the value is XXÄ (german umlaut A)

CREATE DATABASE 'leer.DB' USER 'SYSDBA' PASSWORD 'masterkey' DEFAULT CHARACTER SET WIN1252 collation PXW_INTL;
CREATE TABLE TABZL (ZLKENNZ VARCHAR(3) NOT NULL,PRIMARY KEY (ZLKENNZ));
INSERT INTO TABZL (ZLKENNZ) VALUES ('XXÄ');

this batchjob produces the error:
"%PROGRAMFILES%\Firebird\Firebird_2_5\bin\isql.exe" -q -i CreateErrorDB.sql
"%PROGRAMFILES%\Firebird\Firebird_2_5\bin\gbak.exe" -b leer.db test.fbak -USER SYSDBA -pas masterkey
"%PROGRAMFILES%\Firebird\Firebird_2_5\bin\gbak.exe" -v -user SYSDBA -pas masterkey -C test.fbak test.db

the 2nd gbak command produces this output (only the last lines)
........
gbak:creating indexes
gbak: activating and creating deferred index RDB$PRIMARY1
gbak:cannot commit index RDB$PRIMARY1
gbak: ERROR:connection lost to database
gbak: ERROR:Error writing data to the connection.
gbak:Exiting before completion due to errors
gbak: ERROR:Error writing data to the connection.


 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Oliver Wurdak added a comment - 02/May/14 07:19 PM - edited
I found 2 ways to prevent the error.
1.) change the default collation to WIN1252
CREATE DATABASE 'leer.DB' USER 'SYSDBA' PASSWORD 'masterkey' DEFAULT CHARACTER SET WIN1252 collation WIN1252;
2.) modify the key size
CREATE TABLE TABZL (ZLKENNZ VARCHAR(4) NOT NULL,PRIMARY KEY (ZLKENNZ));

The problem is I have this database in a productive environment. I need to know whether the error is in the core engine or only in the gbak utility?

Adriano dos Santos Fernandes made changes - 12/Jun/14 03:57 PM
Field Original Value New Value
Status Open [ 1 ] Resolved [ 5 ]
Assignee Adriano dos Santos Fernandes [ asfernandes ]
Fix Version/s 2.5.3 [ 10461 ]
Fix Version/s 3.0 Beta 1 [ 10332 ]
Resolution Fixed [ 1 ]
Pavel Zotov made changes - 03/Jun/15 06:29 PM
Status Resolved [ 5 ] Resolved [ 5 ]
Test Details Confirmed crash of restoring on WI-V2.5.2.26540: message about abnnormal program termination appeared.
No any troubles on 2.5.3 and above, including 3.0.
QA Status Done successfully
Pavel Cisar made changes - 25/Sep/15 01:11 PM
Link This issue is related to QA-610 [ QA-610 ]