Issue Details (XML | Word | Printable)

Key: CORE-4465
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Critical Critical
Assignee: Unassigned
Reporter: igor Ferafontov
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

in Range bigint -9223372036854775808 error (or IbEpert Bug )

Created: 18/Jun/14 03:06 PM   Updated: 19/Jun/14 06:31 AM
Component/s: Engine
Affects Version/s: 2.5.2
Fix Version/s: None

Time Tracking:
Not Specified

Planning Status: Unspecified


 Description  « Hide
Write in Stored proc:
BITTOINTMask = -9223372036854775807-1
it is = 8000000000000000(hex)

Error Message:
----------------------------------------
Invalid floating point operation


Thanks !

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Adriano dos Santos Fernandes added a comment - 18/Jun/14 03:25 PM
Cannot reproduce!

Sean Leyne added a comment - 18/Jun/14 03:49 PM
Igor,

Actually, 8000000000000000h = -9223372036854775808 not -9223372036854775807-1

Sean Leyne added a comment - 18/Jun/14 03:50 PM
If you can reproduce using firebird isql tool (the 'gold' standard for all bug reports), please submit an appropriate script and the case will be re-opened.