Issue Details (XML | Word | Printable)

Key: CORE-4510
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Vlad Khorsun
Reporter: Vlad Khorsun
Votes: 0
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Database validation bug can cause AV

Created: 05/Aug/14 02:20 PM   Updated: 25/May/16 06:28 AM
Component/s: Engine, GFIX
Affects Version/s: 3.0 Alpha 1, 3.0 Alpha 2
Fix Version/s: 3.0 Beta 1

QA Status: Cannot be tested


 Description  « Hide
When database physically contains more than pagesPerPIP pages but really used is less than pagesPerPIP pages (i.e. second PIP page is not initialized yet) - it is possible to get AV on validation.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Vlad Khorsun made changes - 05/Aug/14 02:20 PM
Field Original Value New Value
Assignee Vlad Khorsun [ hvlad ]
Sean Leyne added a comment - 05/Aug/14 02:32 PM
1- The description does not really make sense, a clearer explanation is required.

2- Should this be associated with "gfix" component?

Vlad Khorsun added a comment - 05/Aug/14 02:40 PM
Sean

1. make better, if you can
2. no

Sean Leyne added a comment - 05/Aug/14 02:59 PM
1- If I followed what the condition was, I would try to edit.

Is the problem that:

  a database can have pages allocated/defined but not have PIP page(s) not created/initialized for the pages (due to db growth factor)?

Vlad Khorsun added a comment - 05/Aug/14 03:16 PM
No, it is not a problem. It is normal state. The problem is that validation code have a bug which is triggered by this normal state only and this bug leads to AV.
Now try to make short description better than existing one :)

Vlad Khorsun made changes - 05/Aug/14 04:01 PM
Status Open [ 1 ] Resolved [ 5 ]
Fix Version/s 3.0 Beta 1 [ 10332 ]
Resolution Fixed [ 1 ]
Sean Leyne added a comment - 05/Aug/14 04:27 PM
OK

So, why is this not a GFIX problem, since it is the validation logic which has the bug which causes the AV?

Dmitry Yemanov added a comment - 05/Aug/14 05:13 PM
Probably because the database validation code resides inside the engine, GFIX is just an interface to that.

Sean Leyne added a comment - 05/Aug/14 05:19 PM
Aware and understood, but I look at the problem as follows:
- if the error can only occur due to validation condition, and the only way to execute a validation is via the equivalent of gfix... Then the issue should be described/assigned to gfix.

Dmitry Yemanov added a comment - 05/Aug/14 05:33 PM
Validation can also be performed via plain API (exacty what gfix does internally) and via Services API. So maybe both "engine" and "gfix" components should be assigned.

Vlad Khorsun added a comment - 05/Aug/14 05:33 PM
Issue, assigned to component X means issue within that component, isn't is ?
There is no issues with gfix itself.
Validation is a part of the engine and could be run not using gfix (via services).

Sean Leyne made changes - 05/Aug/14 05:40 PM
Summary AV in validation is possible Database validation bug can cause AV
Sean Leyne made changes - 05/Aug/14 05:40 PM
Component/s GFIX [ 10004 ]
Adriano dos Santos Fernandes added a comment - 05/Aug/14 05:45 PM
I think both components should be listed.

Sean Leyne added a comment - 05/Aug/14 06:17 PM
Have edited the subject and link the case to the "engine" and "gfix" components.

Pavel Cisar made changes - 23/Sep/15 11:28 AM
Status Resolved [ 5 ] Closed [ 6 ]
Pavel Zotov made changes - 18/Jan/16 03:28 PM
Status Closed [ 6 ] Closed [ 6 ]
QA Status No test
Pavel Zotov made changes - 25/May/16 06:28 AM
Status Closed [ 6 ] Closed [ 6 ]
QA Status No test Cannot be tested