Issue Details (XML | Word | Printable)

Key: CORE-4557
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Unassigned
Reporter: Pavel Zotov
Votes: 0
Watchers: 5
Operations

If you were logged in you would be able to see more operations.
Firebird Core

FB 3.0 crashes on EXIT (or QUIT) command if use UTF8-collation + create domain based on it + issue SHOW DOMAIN

Created: 23/Sep/14 02:08 PM   Updated: 23/Sep/15 11:29 AM
Component/s: None
Affects Version/s: 3.0 Alpha 2
Fix Version/s: 3.0 Beta 1

File Attachments: 1. Zip Archive e255_appcompat.zip (4 kB)


QA Status: Done successfully


 Description  « Hide
ISQL Version: WI-T3.0.0.31334 Firebird 3.0 Alpha 2
Server version:
WI-T3.0.0.31334 Firebird 3.0 Alpha 2
WI-T3.0.0.31334 Firebird 3.0 Alpha 2/tcp (IT_test)/P13:C
WI-T3.0.0.31334 Firebird 3.0 Alpha 2/tcp (IT_test)/P13:C

The following script being run on new database will lead to FB crash if UNCOMMENT statement: 'show domain'.
Crash seems on EXIT command (also on QUIT one):

create collation name_coll for utf8 from unicode CASE INSENSITIVE;
create collation nums_coll for utf8 from unicode CASE INSENSITIVE 'NUMERIC-SORT=1';
commit;

create domain dm_name as varchar(80) character set utf8 collate name_coll;
create domain dm_nums as varchar(20) character set utf8 collate nums_coll;
commit;

--show domain; -- FB crashes if this will be uncommented
exit;

PS. OS: Win XP 2002 SP 3.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 23/Sep/14 02:25 PM
Can't reproduce on linux:

bin # ./isql
Use CONNECT or CREATE DATABASE to specify a database
SQL> create database 'qq.zz';
SQL> create collation name_coll for utf8 from unicode CASE INSENSITIVE;
SQL> create collation nums_coll for utf8 from unicode CASE INSENSITIVE 'NUMERIC-SORT=1';
SQL> commit;
SQL>
SQL> create domain dm_name as varchar(80) character set utf8 collate name_coll;
SQL> create domain dm_nums as varchar(20) character set utf8 collate nums_coll;
SQL> commit;
SQL> show domain;
       DM_NAME DM_NUMS

SQL>

Version: LI-T3.0.0.31333 Firebird 3.0 Alpha 2, but I do not think it's important.

Pavel Zotov added a comment - 23/Sep/14 02:41 PM
Yes, it's only on windows build (on linux I run this test dozen times in a day :)).

Vlad Khorsun added a comment - 25/Sep/14 08:41 AM
I confirm the crash in client code. Investigating

Simonov Denis added a comment - 01/Oct/14 09:12 AM
On version WI-T3.0.0.31334 Firebird 3.0 Alpha 2 I confirm bug.

On version WI-T3.0.0.31345 Firebird 3.0 Alpha 2 don't reproduce.