Issue Details (XML | Word | Printable)

Key: CORE-4712
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Minor Minor
Assignee: Alexander Peshkov
Reporter: Pavel Zotov
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Messages "Error in isc_release_request() ... when working with legacy security database" appear in firebird.log for CLASSIC server when connecting with legacy auth

Created: 17/Mar/15 07:06 PM   Updated: 18/Jan/16 03:21 PM
Component/s: Security
Affects Version/s: None
Fix Version/s: 3.0 Beta 2

File Attachments: 1. Zip Archive error-in-isc_detach_database-with-legacy-sec-database.zip (66 kB)


QA Status: No test


 Description  « Hide
The following TWO messages:
===
oel64 Tue Mar 17 21:53:05 2015
        Error in isc_release_request() API call when working with legacy security database
        invalid request handle


oel64 Tue Mar 17 21:53:05 2015
        Error in isc_detach_database() API call when working with legacy security database
        invalid database handle (no active connection)
===

-- appear in firebird.log on CLASSIC Server instance when establishing connect from client 2.5 or from client 3.0 which uses 'AuthClient = Legacy_Auth' in its local firebird.conf.
The problem exists ONLY on CLASSIC server.

Files in attach:
1) security3.fdb -- database from server with 3.0 CS instance;
2) server-side-firebird.conf -- firebird.conf from server with 3.0 CS instance;
3) client-side-firebird.conf -- firebird.conf from CLIENT 3.0 installation directory.

When line AuthClient = Legacy_Auth is commented, no new messages on firebird.log (but of course this doesn`t help when connecting using client-2.5)

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
There are no comments yet on this issue.