Issue Details (XML | Word | Printable)

Key: CORE-4715
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Imam Chalimi
Votes: 0
Watchers: 5
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Restore of shadowed database fails using -k ("restore without shadow") switch

Created: 19/Mar/15 02:40 PM   Updated: 14/Jun/15 04:46 PM
Component/s: GBAK
Affects Version/s: 3.0 Beta 2
Fix Version/s: 3.0 Beta 2

File Attachments: None
Image Attachments:

1. gbak_error.jpg
(108 kB)
Environment:
Microsoft Windows 7 32bit RAM 2GB
WI-T3.0.0.31719 Firebird 3.0 Beta 2 (from snapshot build)

QA Status: Done successfully
Test Details:
Confirmed on WI-T3.0.0.31374:
command "gbak -rep -k c4715.fbk -user SYSDBA -pas masterke localhost/3000:<path>\c4715-new.FDB"
produces:
gbak: ERROR:DELETE operation is not allowed for system table RDB$FILES
gbak:Exiting before completion due to errors


 Description  « Hide
an error message "gbak: ERROR:DELETE operation is not allowed for system table RDB$FILES" appears when performing a restore without shadow (-k switch) .

command : C:\VsrProject>gbak -user sysdba -pass masterkey -v -c -r -k data.fbk data_new.fb

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Imam Chalimi added a comment - 19/Mar/15 02:43 PM
error snapshot

Sean Leyne added a comment - 19/Mar/15 03:38 PM
Does the original database have shadow defined/active?

Imam Chalimi added a comment - 19/Mar/15 10:17 PM
yes, original database have shadow, defined and active.
i want to restore to new database without shadow.
I used to do before and no problems.

I think the problem is new firebird does not allow to delete a record in the file system RDB$FILES.