Issue Details (XML | Word | Printable)

Key: CORE-490
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Unassigned
Reporter: jthaddeus
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

GPRE does not recognize COALESCE

Created: 20/Aug/04 12:00 AM   Updated: 20/Aug/16 05:35 PM
Component/s: GPRE
Affects Version/s: None
Fix Version/s: 2.5 Alpha 1

File Attachments: 1. File coalesce_bug.e (3 kB)


SF_ID: 1012895
Target: 2.5.0
QA Status: Cannot be tested


 Description  « Hide
SFID: 1012895#
Submitted By: jthaddeus

GPRE does not recognize the COALESCE function. Upon
reaching the COALESCE line in any code I've tried, an
error is thrown. For example:

$ /opt/firebird/bin/gpre -c -n -m o_process.e
(E) o_process.e:234: expected FROM, encountered "("
(E) o_process.e:302: expected FROM, encountered "("
  2 errors, no warnings

Platform: SuSE Linux 9.0

Firebird installed with:
FirebirdSS-1.5.1.4481-0.i686.tar.gz

For the error above, line 234, looks like

232 ...
232 EXEC SQL
233 SELECT
234 procid, COALESCE(procname,' '), wfmcstate,
235 ...

I have also tried

234 procid, COALESCE(procname,' ') as procname,
wfmcstate,

with similar results.

COALESCE works in ISQL.

The attached file demonstrates the error in a program
written against the employee.fdb. Instructions are in
the file's comments.

NOTE: I have not tired NULLIF or any other function in
ESQL (I've been using my own UDF for NULLIF and
NVL/COALESCE with Firebird 1.0.x).

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Pavel Cisar added a comment - 26/Jun/06 07:39 PM
ESQL program file that demostrates the problems with COALESCE.

Dmitry Yemanov added a comment - 03/Dec/07 11:27 AM
Contributed by Stephen Boyd (sboyd@users.sf.net).