Issue Details (XML | Word | Printable)

Key: CORE-5178
Type: Bug Bug
Status: Open Open
Priority: Critical Critical
Assignee: Unassigned
Reporter: Michael Beilharz
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Different Date/DateTime Handling between FB 2.0 and FB 2.5

Created: 30/Mar/16 02:21 PM   Updated: 31/Mar/16 05:44 AM
Component/s: None
Affects Version/s: 2.5.1
Fix Version/s: None

Environment: Windows
Issue Links:
Relate
 

QA Status: No test


 Description  « Hide
in FB 2.0 Date/DateTIme datas less than 1.1.100 are accepted (there is no sense behind it, but FB 2.0 accept such dates), the porblem is, when you read a record with such a date/datetime column by using an FB 2.5.x, an exception appears "value exceeds the range for valid timestamp".
my question: is there an option or a flag in FB 2.5.x (firebird.conf) to start the FB 2.5.x server by ignoring datas which exceeds the range, so that the FB 2.5.x works in that context as an FB 2.0 ?

thank you for answering and your help

regards
michael

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Dmitry Yemanov added a comment - 30/Mar/16 02:34 PM
No, you cannot turn it off. To troubleshoot impossible gbak's restore, see here: http://paulbeachsblog.blogspot.ru/2011/07/firebird-v21-error-value-exceeds-range.html

Michael Beilharz added a comment - 31/Mar/16 05:44 AM
thanks for your immediate help