Issue Details (XML | Word | Printable)

Key: CORE-5379
Type: Sub-task Sub-task
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Mark Rotteveel
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core
CORE-5278

Regression service API for isc_spb_sts_table

Created: 17/Oct/16 04:03 PM   Updated: 17/Oct/16 04:21 PM
Component/s: API / Client Library, GSTAT
Affects Version/s: 3.0.1
Fix Version/s: 3.0.2

QA Status: No test


 Description  « Hide
Getting stats for partticular table(s) fails, this never used to happen with 2.5.x & 3.0.0.

After upgrading to Firebird 3.0.1 a test that uses the services API to
obtain table statistics nows fails with an exception:

unrecognized service parameter block; All services except for getting
server log require switches [SQLState:42000, ISC error code:335544562]

This test, org.firebirdsql.management.TestFBStatisticsManager method
testGetTableStatistics works fine in 3.0.0 and earlier.

The test itself is:

statManager.getTableStatistics(new String[]{"TEST"});

where getTableStatistics is:

     public void getTableStatistics(String[] tableNames) throws
SQLException {
         // create space-separated list of tables
         StringBuilder commandLine = new StringBuilder();
         for (int i = 0; i < tableNames.length; i++) {
             commandLine.append(tableNames[i]);
             if (i < tableNames.length - 1)
                 commandLine.append(' ');
         }

         try (FbService service = attachServiceManager()) {
             ServiceRequestBuffer srb = createStatsSRB(service,
isc_spb_sts_table);
             srb.addArgument(isc_spb_command_line, commandLine.toString());
             executeServicesOperation(service, srb);
         }
     }

Is the above doing something wrong (if so what?), or is this a regression?

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 17/Oct/16 04:06 PM - edited
Regression was caused by commit for CORE-5278

Alexander Peshkov added a comment - 17/Oct/16 04:21 PM
Code in master branch also fixed but bug was not released except snapshots therefore not mentioned in fix versions.