Issue Details (XML | Word | Printable)

Key: CORE-5456
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Blocker Blocker
Assignee: Dmitry Yemanov
Reporter: erkankurtaga
Votes: 0
Watchers: 5
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Migrating Firebird 2.5.2 to 3.0.1 gbak restore crashes at the end always

Created: 17/Jan/17 07:45 AM   Updated: 10/Feb/17 08:39 AM
Component/s: GBAK
Affects Version/s: 3.0.1
Fix Version/s: 3.0.2, 4.0 Alpha 1

File Attachments: 1. Zip Archive 29122016_171826.zip (3.42 MB)

Environment: Code editor Delphi XE4+. Component Firedac or IBSQL, OS:Windows XP+

QA Status: Deferred
Test Details:
Restoring process takes about 1 minute (too long).
After discuss with dimitr it was decided to try another method, without using supplied .fbk
Waiting for sketch / suggestion from dimitr, letter: 10-feb-2016 11:16


 Description  « Hide
When Migrating Firebird 2.5.2 to 3.0.1 gbak restore crashes at the end always. We use Delphi XE4 and over and our database components IBSQL and Firedac, I tried restore with command prompt, components restore api and IBExpert restore at its editor manually. Always the same error :

gbak:creating indexes
gbak:committing metadata
gbak:fixing views dbkey length
gbak:updating ownership of packages, procedures and tables
gbak:adding missing privileges
gbak:fixing system generators
IBE: Unsuccessful execution caused by a system error that precludes successful execution of subsequent statements.
     Error reading data from the connection.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Dmitry Yemanov added a comment - 17/Jan/17 07:53 AM
Did you try restoring with any recent v3.0.2 snapshot build?

erkankurtaga added a comment - 17/Jan/17 12:10 PM
No, I didn't try. I setup the recent v3.0.2 snapshot build, but user adding to firebird very difficult . I use "gsec -add SYSDBA -pass masterkey" command but gsec gives error like that :

use gsec -? to get help
Your user name and password are not defined. Ask your database administrator to
set up a Firebird login.
unable to open database

Because of this ı didn't try. Sorry

erkankurtaga added a comment - 17/Jan/17 01:15 PM
I could create SYSDBA and tried restore with 3.0.2 snapshot. Result is the same. We couldn't restore database !

erkankurtaga added a comment - 17/Jan/17 01:27 PM
Here is the gbak restore with command at the end Windows 7 Pro error:

Problem Event Name: APPCRASH
Application Name: gbak.exe
Application Version: 3.0.1.32609
Application Time Stamp: 57ea2882
Error Module Name: Engine12.DLL
Error Module Version: 3.0.1.32609
Error Module Time Stamp: 57ea2830
Exception Status Code: c0000005
Exception Status: 000d4db4
OS Version: 6.1.7601.2.1.0.256.1
Local ID: 1055
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Further Information 4: 0a9e372d3b4ad19135b953a78882e789

erkankurtaga added a comment - 19/Jan/17 12:27 PM
Anyone else who answer me, please...

Dmitry Yemanov added a comment - 19/Jan/17 12:38 PM
Please also try metadata only restore (-m switch) - whether it crashes or not. And main question: can you provide your backup to FB developers in order to fix the issue?

erkankurtaga added a comment - 19/Jan/17 12:48 PM
Metadata Restore has the same error. FBK is at the attachment.

Dmitry Yemanov added a comment - 19/Jan/17 05:02 PM
Confirmed.

Vlad Khorsun added a comment - 19/Jan/17 05:18 PM
Looks like CORE-5457: same assert in CMP_format() at debug build.

erkankurtaga added a comment - 20/Jan/17 06:49 AM - edited
I tried new snapshot but the problem is continue:

Problem Event Name: APPCRASH
   Application Name: gbak.exe
   Application Version: 3.0.2.32672
   Application Time Stamp: 58819ccf
   Error Module Name: Engine12.DLL
   Error Module Version: 3.0.2.32672
   Error Module Time Stamp: 58819c87
   Exception Status Code: c0000005
   Exception Status: 000d5534
   OS Version: 6.1.7601.2.1.0.256.1
   Local ID: 1055
   Additional Information 1: 0a9e
   Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
   Additional Information 3: 0a9e
   Further Information 4: 0a9e372d3b4ad19135b953a78882e789

Dmitry Yemanov added a comment - 20/Jan/17 09:20 AM
Snapshot containing the bugfix will be available tomorrow.