Issue Details (XML | Word | Printable)

Key: CORE-5498
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Vlad Khorsun
Reporter: Solcraft Programetajs
Votes: 0
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Cannot create connection for DB Events.

Created: 07/Mar/17 12:11 PM   Updated: 15/Mar/17 05:08 AM
Component/s: API / Client Library
Affects Version/s: 3.0.2
Fix Version/s: 3.0.2, 4.0 Alpha 1

File Attachments: None
Image Attachments:

1. ^D265B320DF24F3E9B4BC6F149610845FC7F5724E0F5E341730^pimgpsh_fullsize_distr.png
(85 kB)
Environment: CentOS Linux release 7.2.1511 (Core); Ubuntu 16.04.2 LTS; (both 64 bit), sestatus=DISABLED; firewall is switched off

QA Status: Cannot be tested
Test Details: " if client and server OS have different definitions of AF_INET6 constant." - n/a for current test evrironment
Test Specifics: Platform (Windows/Linux) specific


 Description  « Hide
Error message:
'Unable to complete network request to host "192.168.1.234".
Failed to establish a secondary connection for event processing.
The requested address is not valid in its context. '.

Client 2.5 fbclient.dll, server linux 3.0.2 - OK
Client 3.0.2 fbclient.dll, server windows 8.1 Pro - OK
Client 3.0.2 fbclient.dll, server linux 3.0.2 - Error


 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 10/Mar/17 02:56 PM
I've rechecked events with fresh 3.0.2 client and server. I've used execute block to post event:

localhost bin # ./isql -z -user sysdba -pas masterkey localhost:employee
ISQL Version: LI-V3.0.2.32691 Firebird 3.0
Server version:
LI-V3.0.2.32692-dev Firebird 3.0
LI-V3.0.2.32692-dev Firebird 3.0/tcp (localhost)/P14:C
LI-V3.0.2.32691 Firebird 3.0/tcp (localhost)/P14:C
Database: localhost:employee, User: SYSDBA
SQL> set term ^;
SQL> execute block as begin post_event 'ABC'; end^
SQL> commit^
SQL>

I've used flamerobin to monitor events:
17:50:00 Monitoring started
17:50:52 ABC (1)

If you want us to check something else please provide full reproducible test case.

Solcraft Programetajs added a comment - 13/Mar/17 12:49 PM
Server: CentOS Linux;
Client : Windows 7, 64 bit.

I tried your test and there was not error but when i copied fbclient.dll (32.bit) in flamerobin folder i have got an error.


[Window Title]
Unhandled Error in FlameRobin

[Content]
*** IBPP::SQLException ***
Context: EventsImpl::Queue
Message: isc_que_events failed

SQL Message : -902
can't format message 13:98 -- message file C:\Program Files (x86)\FlameRobin\firebird.msg not found

Engine Code : 335544721
Engine Message :
Unable to complete network request to host "192.168.1.33".
Failed to establish a secondary connection for event processing.
The requested address is not valid in its context.


[OK]

Solcraft Programetajs added a comment - 13/Mar/17 12:55 PM
Screen shot

Vlad Khorsun added a comment - 13/Mar/17 04:48 PM
The problem is very specific, it happens only if client and server uses ipv6 and if client and server OS have different definitions of AF_INET6 constant.
On Linux it is defined as 10 while on Windows it have value of 23.
Fix is committed into master branch, will be backported after review.