Issue Details (XML | Word | Printable)

Key: CORE-5597
Type: Bug Bug
Status: Closed Closed
Resolution: Duplicate
Priority: Minor Minor
Assignee: Unassigned
Reporter: Slavomir Skopalik
Votes: 0
Watchers: 3
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Failing isc_que_events causes that other operations with DB on same handle are blocked

Created: 24/Aug/17 02:40 PM   Updated: 26/Feb/18 03:54 PM
Component/s: API / Client Library
Affects Version/s: 2.5.7
Fix Version/s: None

Environment: Windows, DelphiXE7, simplified (no thread) implementation of IBEvent
Issue Links:
Duplicate
 

QA Status: No test


 Description  « Hide
32 bits gds32.dll from 2.5.7
In case that connection to DB was successfully but auxiliary event connection failed to establish, other operations on same DB handle are blocked.

Call of isc_cancel_events not help.

If I use fbclient.dll from Firebird-3.0.3.32798-0_Win32, it is working fine.




 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Vlad Khorsun added a comment - 16/Sep/17 06:47 AM
Could you provide us with reproducible test case ?

Slavomir Skopalik added a comment - 17/Sep/17 09:32 AM
Test is simple:
1. Configure FB server but on firewall open only 3050. Block all other ports.
2. On client side connect to DB (this will be successful)
3. Try to register events. but this will failed due to server firewall.
4. After that, you cannot do any operation with DB using handle obtained in step 2.


Vlad Khorsun added a comment - 22/Feb/18 10:39 PM
Is it the same as CORE-3718 ?

Slavomir Skopalik added a comment - 23/Feb/18 08:10 AM
Yes, it is same. Sorry I miss it.