Issue Details (XML | Word | Printable)

Key: CORE-5745
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Gabor Boros
Votes: 0
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
Firebird Core

GRANT privileges error during database restore

Created: 10/Feb/18 05:48 PM   Updated: 21/Feb/18 03:39 AM
Component/s: None
Affects Version/s: 3.0.0, 3.0.1, 3.0.2, 3.0.3
Fix Version/s: 3.0.4

QA Status: Deferred
Test Details:
Can not reproduce (no errors during restore) . Sent letter 17-feb-18 14:18, waiting for reply.


 Description  « Hide
I have a very minimal database, just created it and added some SQL users into it. After execute the script which create tables, etc. make a backup with gbak. At restore the below error message appears.

gbak: ERROR:action cancelled by trigger (2) to preserve data integrity
gbak: ERROR: user does not have GRANT privileges for operation
gbak:Exiting before completion due to errors



 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 10/Feb/18 05:59 PM
Bug was due to missing check for database owner (not sysdba) in system triggers.
Note - there is no need to front-port it to master branch cause related checks are done in it using RDB$SYSTEM_PRIVILEGE system function which correctly performs all required checks.