Issue Details (XML | Word | Printable)

Key: CORE-5756
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Dmitry Yemanov
Reporter: Pavel Zotov
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Regression: FB crashes when trying to recreate table that is in use by DML (3.0.3; 3.0.4; 4.0.0)

Created: 21/Feb/18 04:42 AM   Updated: 23/Feb/18 09:16 AM
Component/s: Engine
Affects Version/s: 4.0 Alpha 1, 3.0.3
Fix Version/s: 3.0.4, 4.0 Beta 1

File Attachments: 1. File gdb-crash-when-tried-to-recreate-table-that-was-in-use.7z (4 kB)


QA Status: Done successfully


 Description  « Hide
Try to run following script:
===
shell rm -f /var/tmp/tmptest.fdb;
create database 'localhost:/var/tmp/tmptest.fdb' user 'SYSDBA'password 'masterkey';

set list on;
set echo on;

recreate table test(x int);
select 1 from test;
recreate table test(x int, y int);
===

Output will be:
-------------------
Statement failed, SQLSTATE = 08006
Error reading data from the connection.
After line 8 in file /opt/scripts/recreate-used-table.sql
Statement failed, SQLSTATE = 08006
Error writing data to the connection.
------------------

I can reproduce this on 3.0.3.32875, 3.0.4.32819 and 4.0.0.853.
Stack traces for 3.0.3 and 3.0.4 seems to be equal, but i attach them both.

2.5.x is not afttected and raised expected error:
===
Statement failed, SQLSTATE = 42000
unsuccessful metadata update
-object TABLE "TEST" is in use
===

PS. Used config:

BugCheckAbort=1
RemoteServicePort = 3333
IpcName = fb30ss

Providers = Remote,Engine12,Loopback
#Providers = Remote,Loopback
#Providers = Engine12

AuthServer = Srp, Win_Sspi, Legacy_Auth
AuthClient = Srp, Win_Sspi, Legacy_Auth
UserManager = Srp,Legacy_UserManager
WireCrypt = Enabled
#WireCompression = false


 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Dmitry Yemanov added a comment - 21/Feb/18 07:07 AM
Introduced due to CORE-2284 / CORE-5677.