Issue Details (XML | Word | Printable)

Key: CORE-5844
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Critical Critical
Assignee: Vlad Khorsun
Reporter: Ivan Diez
Votes: 0
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Firebird freeze for new connections

Created: 11/Jun/18 02:38 PM   Updated: 27/Jul/18 07:48 AM
Component/s: None
Affects Version/s: 4.0 Initial, 3.0.0, 3.0.1, 3.0.2, 4.0 Alpha 1, 3.0.3
Fix Version/s: 3.0.4, 4.0 Beta 1

Environment: Production

QA Status: No test


 Description  « Hide
Hi,

sometime we have the firebird seems to be frozen and no new connection are allowed. I mean, people working with the app can work normally but people who tries to opens the app cannot., even when we try to open a direct database connection (flamerobin) it's impossible.

Please help!!

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Vlad Khorsun added a comment - 11/Jun/18 04:23 PM
Specify, please:
- OS name, version and bitness
- Firebird architecture and bitness
- changed settings at firebird.conf
- messages at firebird.log

Ivan Diez added a comment - 12/Jun/18 05:59 AM
The server OS version is a Windows 2008 R2 Standard
Firebird installation is a SuperServer v3.0.1
No change on firebird.conf
and the is the latest message we got at firebird.log: INET/inet_error: read errno = 10054 This error message is repeated thousand of times in the log file

kind regards

Vlad Khorsun added a comment - 13/Jun/18 11:49 AM
Ivan,

please, answer *all* questions.

Could you try latest release v3.0.3 ?
Could you provide us with full memory dump when some new connection is freezed ?

Vlad Khorsun added a comment - 19/Jun/18 08:57 AM
Ivan,

without info i requested i'll be forced to close this ticket as incomplete, sorry

Sorien added a comment - 24/Jul/18 02:13 PM - edited
FB 3.0.3, it happens all the time when i terminate application (client with multiple connections and events)
in 3.0.4 (from 24.7.2018) its partially fixed but still present from time to time

Sorien added a comment - 25/Jul/18 01:24 PM - edited
Dump from 3.0.4.33011 (64bit) SuperServer - 1 active client app with 5 connections opened

www.merkuris.sk/files/firebird.zip

and dump when i try to open new connection while server is "frozen"

www.merkuris.sk/files/firebird_2.zip

Vlad Khorsun added a comment - 25/Jul/18 02:54 PM
Thanks, dump show how the issue happens.
Could you reproduce the ussue and, if yes, would you like to test custom build with patch ?

Sorien added a comment - 25/Jul/18 06:02 PM
i can reproduce it, but it takes same time, if you prepare binary i'll test it immediately

Vlad Khorsun added a comment - 25/Jul/18 09:55 PM
Please, test next snapshot build (after 33012)

Sorien added a comment - 26/Jul/18 08:07 AM
after 2 hours of testing i can't reproduce it anymore, i had 2 server crashes but don't have memory dumps, when i get them i'll create new issue, but this issue seems to be fixed for me

Vlad Khorsun added a comment - 26/Jul/18 08:15 AM
Thank you for confirmation!

I have no idea if it is the same case as was initially reported by Ivan Diez, but,
as he is silent for more than a month, i'll close this ticket as resolved.

Vlad Khorsun added a comment - 26/Jul/18 08:19 AM
The issue is related with events processing and could happens when POST_EVENT run by ON DISCONNECT trigger .
Also, application doesn't cancel events when disconnects - i reproduced it by killing application.

Sorien added a comment - 26/Jul/18 08:43 AM - edited
i got dump from server crash during testing this issue FB 64bit (3.0.4.33014)

www.merkuris.sk/files/firebird_3.zip

i can confirm that we are using EVENT fired from ON DISCONNECT TRIGGER

Ivan Diez added a comment - 27/Jul/18 07:48 AM
Hi Vlad / Sorien,

I cannot connect time ago due a personal issue.

Thanks to track and solve the issue, I'm more than excited to download the version 3.0.4 to found it solved!!

Best regards
Iván