Issue Details (XML | Word | Printable)

Key: CORE-5866
Type: Bug Bug
Status: Closed Closed
Resolution: Won't Fix
Priority: Minor Minor
Assignee: Alexander Peshkov
Reporter: Maxim Kuzmin
Votes: 0
Watchers: 4
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Trusted Auth and long login with non-english characters

Created: 08/Jul/18 11:59 PM   Updated: 28/Aug/18 12:40 PM
Component/s: None
Affects Version/s: 3.0.3
Fix Version/s: None

Issue Links:
Relate

QA Status: No test


 Description  « Hide
We using Windows trusted authentication (FB 3.0) and user login's with non-english characters as surname and initials. But in case of long a surname (like "DOMN\КрасноруцкаяАА"), error occurs: "Login name too long (33 characters, maximum allowed 31) and user can't attachment to database.


 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Sean Leyne added a comment - 09/Jul/18 03:48 PM
User ID string are Object IDs, thus are restricted to the limitations which applies to all database objects (31 characters).

The implementation of Trusted Auth functionality is constrained by the systemic/engine/base schema limitations.

Alexander Peshkov added a comment - 24/Jul/18 10:37 AM
An issue will be gone in FB4 - it has increased limit of SQL identifiers length (63 unicode chars). In FB3 you can avoid this using mapping - create mapping from "DOMN\КрасноруцкаяАА" to something like "DOMN\Krasnorutskaya".

Sean Leyne added a comment - 24/Jul/18 05:42 PM
Create a "mapping" how?

Alexander Peshkov added a comment - 25/Jul/18 07:27 AM - edited
CREATE MAPPING Krasnorutskaya USING PLUGIN WIN_SSPI FROM USER 'DOMN\КрасноруцкаяАА' TO USER "DOMN\Krasnorutskaya";

And yes - there is a bug to fix: global mapping can not be created.

Alexander Peshkov added a comment - 28/Aug/18 10:58 AM
Mentioned behavior is as designed and not a bug. SQL identifier length is extended in FB4 but it's also limited.