Issue Details (XML | Word | Printable)

Key: CORE-5879
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Vlad Khorsun
Reporter: Sorien
Votes: 0
Watchers: 4
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Error reading/writing data to connection

Created: 26/Jul/18 11:02 AM   Updated: 08/Apr/19 02:04 PM
Component/s: Engine
Affects Version/s: 3.0.0, 2.5.7, 3.0.4
Fix Version/s: 3.0.4, 4.0 Beta 1

Environment: Server env: Windows 10 / 2016 64Bit, clients mostly Windows 10 64Bit,

QA Status: Not enough information


 Description  « Hide
We are getting random error reading/writing data to/from connection, affecting all our users with servers version 2.5.7, 3.0.2-4 64Bit super server (local and remote servers), errors are mostly random, minutes even seconds after connection is established (there are no keep alive time changes)

at https://merkuris.sk/files/firebirdMK.zip you can find dump obtained from 3.0.4.33011 (64bit) SuperServer running at localhost (Error: -902 error writing data to connection, ~5s after conection established)

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Vlad Khorsun added a comment - 26/Jul/18 11:48 AM
The Firebird process is not crashed, you just take a memory dump from live process, correct ?
Any messages in firebird.log ?

Sorien added a comment - 26/Jul/18 12:19 PM
yes, firebird.exe did not crash, there is no errors in firebird.log from today

Vlad Khorsun added a comment - 26/Jul/18 12:28 PM
Then i see no sign of problem at Firebird side.
Idle network connection could be broken by intermediate SW\HW entities (such as firewall, switch, etc).

Sorien added a comment - 26/Jul/18 12:44 PM
problem is that we have like hundreds such reports everyday and our devs see them every day even server and client app are at same machine ... we will investigate more

Sorien added a comment - 30/Jul/18 01:17 PM - edited
after some investigation it seems to be caused by same server crash reported in http://tracker.firebirdsql.org/browse/CORE-5880

dump www.merkuris.sk/files/firebird.exe_180730_150924.zip (FB 3.0.4.33011)

Vlad Khorsun added a comment - 10/Aug/18 04:21 PM
Could you test last build from CORE-5880 ? It contains some patches that could fix this crash too