Issue Details (XML | Word | Printable)

Key: CORE-5880
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Vlad Khorsun
Reporter: Sorien
Votes: 0
Watchers: 5
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Unhandled: C0000005.ACCESS_VIOLATION

Created: 26/Jul/18 11:22 AM   Updated: 31/Aug/18 12:45 PM
Component/s: Engine
Affects Version/s: 3.0.4
Fix Version/s: 3.0.4, 4.0 Beta 1

Environment: 3.0.4.33011, 3.0.4.33014

QA Status: No test


 Description  « Hide
while testing http://tracker.firebirdsql.org/browse/CORE-5844 I got few server crashes, dumps below

www.merkuris.sk/files/firebird_3.zip (3.0.4.33014 64Bit)
www.merkuris.sk/files/firebird_av_1.zip (3.0.4.33011 32Bit)

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Vlad Khorsun added a comment - 26/Jul/18 11:47 AM
firebird_3 dump is related with events processing
Reproducible test case could help us to investigate issue

firebird_av_1 is produced by 32-bit build which i don't have.
Without .pdb and .exe\.dll files it is impossible to analyze memory dump

Sorien added a comment - 26/Jul/18 12:36 PM
here is your's 32bit version https://www.merkuris.sk/files/Firebird-3.0.4.33011-0_Win32.zip with pdb as i see

on our end there is just

simple query that is fetching users and permissions from our table in separate connection

and database trigger

RECREATE TRIGGER DISCONNECT_SHEDULER
  ACTIVE ON DISCONNECT POSITION 0
AS
DECLARE VARIABLE param INTEGER = 0;
BEGIN
SELECT COUNT(*) FROM SHEDULER s INNER JOIN MON$ATTACHMENTS a ON s.client = a.MON$ATTACHMENT_ID into param;
    IF (param = 0) then
        POST_EVENT 'EVENT_SHEDULER';
END ^^

but app is not listening for event EVENT_SHEDULER

and occasionally server will crash, i'll try to create simple demo but don't thing that it will be reproducible easily


 


Vlad Khorsun added a comment - 26/Jul/18 09:10 PM
Could you test this patched build (Win64), please ?

http://ge.tt/8nrSJlq2

Sorien added a comment - 30/Jul/18 07:22 AM - edited
i have tried that version and there is still same server crash, if you need dump just let me know


i'll try to remove that database trigger, it looks like its causing our problems and it's not so important

Sorien added a comment - 30/Jul/18 07:36 AM
disabling that trigger did not help

crash dump (for your build http://ge.tt/8nrSJlq2)

merkuris.sk/files/firebird.exe_180730_093046.zip

Vlad Khorsun added a comment - 30/Jul/18 04:06 PM
Another races and new build to test http://ge.tt/7wKaGpq2

Sorien added a comment - 31/Jul/18 06:45 AM - edited
still crashing

dump https://www.merkuris.sk/files/firebird.exe_180731_084234.zip

maybe it will help, for testing i'm force terminating our app during these queries https://gist.github.com/Sorien/558c028ee20157a3976b2c283f356a0b

Vlad Khorsun added a comment - 31/Jul/18 02:30 PM
New build here: http://ge.tt/8P16bqq2


Sorien added a comment - 01/Aug/18 06:49 AM
it seems to be harder to crash server

 https://www.merkuris.sk/files/firebird.exe_180801_084732.zip

Vlad Khorsun added a comment - 01/Aug/18 12:13 PM
Could you also provide us with firebird.log, if it is not empy ?

Sorien added a comment - 01/Aug/18 01:35 PM

Vlad Khorsun added a comment - 02/Aug/18 09:58 PM
This build contains some extra logging :
http://ge.tt/5Op3qsq2

Please, remove (or clear) firebird.log before run this build and provide me with both memory dump and firebird.log on next crash

Sorien added a comment - 03/Aug/18 08:15 AM - edited
after 2 hours of testing i'm not able crash that build, will try to find more testers and provide logs when it happens

Edit: dump (firebird.log) is inside archive
www.merkuris.sk/files/firebird.exe_180803_103833.zip

Vlad Khorsun added a comment - 03/Aug/18 09:26 AM
Seems that logging makes harder to reproduce the issue, sad.
Anyway, could you provide firebird.log to me ?

Sorien added a comment - 03/Aug/18 10:17 AM
firebird.log is inside zip archive

Vlad Khorsun added a comment - 03/Aug/18 10:42 AM
What archive ? ;)

Sorien added a comment - 03/Aug/18 11:40 AM
www.merkuris.sk/files/firebird.exe_180803_103833.zip

(i edited my last post after server crashed)

Vlad Khorsun added a comment - 07/Aug/18 08:37 AM
Thanks, log helped, but i need a bit more info

A new build with more logging: http://ge.tt/6f5e2wq2

BTW, have you cleaned all INET errors from the firebird.log before put it into archive with dump ?

Sorien added a comment - 07/Aug/18 08:46 AM
that one was from my colleague, it was not changed in any way, on his machine he is able to reproduce it without killing our software

Sorien added a comment - 07/Aug/18 09:07 AM
after few tries server did not crashed but can't attach to db anymore

and in firebird.log i have

PC Tue Aug 07 11:04:01 2018
Authentication error
connection shutdown


Vlad Khorsun added a comment - 07/Aug/18 09:14 AM
There should be much more messages in the log...

Sorien added a comment - 07/Aug/18 09:25 AM

Sorien added a comment - 07/Aug/18 09:28 AM

Vlad Khorsun added a comment - 07/Aug/18 09:51 AM
Found mine error, i'm sorry
Please, try fixed build http://ge.tt/9IUM6wq2

Sorien added a comment - 07/Aug/18 10:48 AM
here is crash dump + log (for your last build)

http://merkuris.sk/files/firebird.exe_180807_123834.zip

in firebird.log i just replaced db name to FOO.fdb

Sorien added a comment - 07/Aug/18 02:03 PM

Vlad Khorsun added a comment - 07/Aug/18 11:14 PM
Thanks, looks like i found a bug reason.
New build: http://ge.tt/5gKNfwq2

Sorien added a comment - 08/Aug/18 12:40 PM
it looks good so far no crash, i'll test more and report back

Vlad Khorsun added a comment - 10/Aug/18 09:39 AM
If there is no more issues, i going to commit patch and close the ticket.
Thanks for the testing !

Sorien added a comment - 31/Aug/18 12:45 PM
I can confirm there are no more such issues. May I ask if there are any plans to release 3.0.4 stable version anytime soon?, cause it fixes our stability issues and it's its i bit difficult to ask admins update to nightly :)