Issue Details (XML | Word | Printable)

Key: CORE-5886
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Sergey Nikitin
Votes: 0
Watchers: 5
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Nbackup does not work after 32K of backups iterations

Created: 08/Aug/18 08:39 AM   Updated: 24/Aug/18 03:08 PM
Component/s: None
Affects Version/s: 3.0.3
Fix Version/s: 3.0.4, 4.0 Beta 1

QA Status: No test


 Description  « Hide
After 32k of incremental backups the RDB$BACKUP_ID in RDB$BACKUPS seems to be frozen - it does not grow
and the new iteration of the nbackup contains the incorrect value of the previous backup GUID.

It seems like there is a truncation here:
   SSHORT value = (SSHORT) DYN_UTIL_gen_unique_id(tdbb, dyn_id, name);

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 24/Aug/18 03:08 PM
Regression was introduced in FB3, 2.5 needs no fix.