Issue Details (XML | Word | Printable)

Key: CORE-5933
Type: Bug Bug
Status: Open Open
Priority: Critical Critical
Assignee: Unassigned
Reporter: Luděk Janča
Votes: 0
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
Firebird Core

incompatible RPM with CentOS 7

Created: 01/Oct/18 10:27 AM   Updated: 02/Oct/18 10:20 AM
Component/s: None
Affects Version/s: 2.5.8
Fix Version/s: None

Environment: CentOS Linux release 7.5.1804 (Core) 64bit

QA Status: No test


 Description  « Hide
I have problem with error "bad parameters on attach or create database CHARACTER SET WIN1250 is not defined" which is "solved" here http://tracker.firebirdsql.org/browse/CORE-5925

So, I tried to install original RPM from firebirdsql.org. This package is incompatible with CentOS 7:

yum install FirebirdSS-2.5.8.27089-0.amd64.rpm
Loaded plugins: fastestmirror
Examining FirebirdSS-2.5.8.27089-0.amd64.rpm: FirebirdSS-2.5.8.27089-0.amd64
Cannot add package FirebirdSS-2.5.8.27089-0.amd64.rpm to transaction. Not a compatible architecture: amd64
Error: Nothing to do

Why isn't here x86_64?

When I try to use rpm utility, it returns:
rpm -ivh FirebirdSS-2.5.8.27089-0.amd64.rpm
Preparing... ################################# [100%]
        file / from install of FirebirdSS-2.5.8.27089-0.amd64 conflicts with file from package filesystem-3.2-25.el7.x86_64
        file /usr/lib64 from install of FirebirdSS-2.5.8.27089-0.amd64 conflicts with file from package filesystem-3.2-25.el7.x86_64

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 01/Oct/18 10:45 AM
When 17 years ago we started to provide binaries in rpm format we did not know that it will become so different for various linux distro. Sorry, our project can't provide rpms (we finally stopped doing this since FB3). Please use .tar.gz instead. Among other it correctly detects what directory to use - lib or lib64.

Mark Rotteveel added a comment - 01/Oct/18 06:50 PM
Note that amd64 **is** x86_64.

Luděk Janča added a comment - 02/Oct/18 05:58 AM - edited
That's sad. Coz when it works from tarball, it should works from RPM. RPM can be just about copy binaries here, config here and init scripts here.

And what about docker containers? Are you planing it? Easy to build image, easy to deploy. And works everywhere. Easy example of dockerfile can see here:
https://hub.docker.com/r/jacobalberty/firebird/~/dockerfile/


And about amd64 vs x86_64. Yes, both are 64bit. But as you can see above amd64 !== x86_64.

Alexander Peshkov added a comment - 02/Oct/18 10:17 AM
Mark, to be precise x86_64 is amd64 - under amd64 name this architecture arrived (compare ia64).

Adriano dos Santos Fernandes added a comment - 02/Oct/18 10:20 AM
Luděk, I use docker a lot, including with Firebird.

I think it would be good if the project has a official image, but anyway, it's so easy to do it manually and customized the way each one wants...