Issue Details (XML | Word | Printable)

Key: CORE-5939
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Minor Minor
Assignee: Alexander Peshkov
Reporter: Basil A. Sidorov
Votes: 0
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Crash for "gbak -se -b database nul"

Created: 10/Oct/18 08:28 PM   Updated: 08/Apr/19 12:42 PM
Component/s: GBAK
Affects Version/s: 2.5.8
Fix Version/s: 2.5.9

Environment: Windows 7 SP1 x64

QA Status: Done with caveats
Test Details: Note. Bug still reproduced on WI-V2.5.9.27117 Classic (snapshot date: 29-sep-2018).


 Description  « Hide
For some test I use nul device as target for backup:
gbak -b host/port:alias nul

It's work fine:
--
2.5.8\bin\gbak -z -b -g -e -st tdwr -v -y .log localhost/12580:employee nul
--
gbak:gbak version WI-V2.5.8.27089 Firebird 2.5
gbak: Version(s) for database "localhost/12580:employee"
Firebird/x86-64/Windows NT (access method), version "WI-V2.5.8.27089 Firebird 2.5"
Firebird/x86-64/Windows NT (remote server), version "WI-V2.5.8.27089 Firebird 2.5/tcp (basid)/P12"
Firebird/x86-64/Windows NT (remote interface), version "WI-V2.5.8.27089 Firebird 2.5/tcp (basid)/P12"
on disk structure version 11.2
gbak: time delta reads writes
gbak: 0.026 0.026 43 0 readied database localhost/12580:employee for backup
gbak: 0.026 0.000 0 0 creating file nul
gbak: 0.026 0.000 0 0 starting transaction
gbak: 0.029 0.002 14 1 database localhost/12580:employee has a page size of 4096 bytes.
...
gbak: 0.136 0.000 0 0 closing file, committing, and finishing. 83968 bytes written
gbak: 0.137 0.000 169 2 total statistics
--


It will crash on gbak 2.5.8 if I add -se option:
--
2.5.8\bin\gbak -z -b -g -e -st tdwr -v -y .log localhost/12580:employee nul -se
--
gbak: ERROR:service name parameter missing
gbak:Exiting before completion due to errors
--
Fault app: gbak.exe, version: 2.5.8.27089, timestamp: 0x5a4f41f1
Fault module: KERNELBASE.dll, версия: 6.1.7601.24231, timestamp 0x5b6db5dd
Exception code: 0xe06d7363
Error offset: 0x000000000001a06d
PID: 0x108c
Run timestamp: 0x01d460d4d7fb0b57
Fault app path: C:\Program Files\FB\2.5.8\bin\gbak.exe
Fault module path: C:\Windows\system32\KERNELBASE.dll
Report code: 1677c72a-ccc8-11e8-8c71-1c1b0d4b372c
   gbak.exe
   2.5.8.27089
   5a4f41f1
   KERNELBASE.dll
   6.1.7601.24231
   5b6db5dd
   e06d7363
   000000000001a06d
   108c
   01d460d4d7fb0b57
   C:\Program Files\FB\2.5.8\bin\gbak.exe
   C:\Windows\system32\KERNELBASE.dll
   1677c72a-ccc8-11e8-8c71-1c1b0d4b372c

P.S.
GBAK 3.0.4 print (same) error message without crash.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Basil A. Sidorov added a comment - 10/Oct/18 08:44 PM
Mea culpa: bad syntax - bad result.
But crash - bad also.

Alexander Peshkov added a comment - 28/Dec/18 04:10 PM
Needs no front-porting - appropriate changes are already present starting with FB3.