Issue Details (XML | Word | Printable)

Key: CORE-5959
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Vlad Khorsun
Reporter: Dimitry Sibiryakov
Votes: 0
Watchers: 3
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Firebird returns wrong time after changes of time zone

Created: 05/Nov/18 11:14 AM   Updated: 13/Nov/18 11:52 AM
Component/s: Engine
Affects Version/s: 4.0 Alpha 1, 3.0.4
Fix Version/s: 4.0 Beta 1, 3.0.5

Environment: Windows

QA Status: No test


 Description  « Hide
If you open date/time control panel and change time zone, Firebird will return wrong time until restart. It is caused by MSVC runtime caching current time zone offset in global variables.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Sean Leyne added a comment - 05/Nov/18 03:14 PM
Dimitry,

Given that the source of the problem with functionality outside of the engine's control, what do you think the appropriate fix should be?


Vlad Khorsun added a comment - 09/Nov/18 11:04 AM
The patch is committed into master, please verify