Issue Details (XML | Word | Printable)

Key: CORE-6097
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Dmitry Yemanov
Reporter: Maxim Kuzmin
Votes: 0
Watchers: 3
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Connection does not see itself in the MON$ATTACHMENTS when Domain/Username (using SSPI) is 31 bytes long

Created: 10/Jul/19 07:45 AM   Updated: 25/Jul/19 10:41 AM
Component/s: None
Affects Version/s: 3.0.4
Fix Version/s: 3.0.5, 4.0 Beta 2

QA Status: Done with caveats
Test Details: See notes in .fbt file.


 Description  « Hide
We using trusted auth (Mapped from Win_Sspi) and our users have a login in Russian.
When FIO is very long, connect is not estabilished (CORE-5866).
When FIO have 13 symbols,connection to the database passes without problems, but "select * from mon$attachments" returns 0 rows.
An example of such a user: DOMN\КовалевскаяАА.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Maxim Kuzmin added a comment - 10/Jul/19 07:51 AM
Add: In CORE-5866 length FIO is 14 symbols and is more than 31 (14 * 2 + 5 = 33).
There - 13 symbols. 13 * 2 + 5 = 31 symbols. The problem is when the name is 31 characters long.

Alexander Peshkov made changes - 10/Jul/19 08:06 AM
Field Original Value New Value
Assignee Alexander Peshkov [ alexpeshkoff ]
Dmitry Yemanov added a comment - 10/Jul/19 08:12 AM
Monitoring truncates the stored user name to 31 bytes but no terminator byte is added when strncpy copied exactly 31 bytes. The fix should be one-liner.

Sean Leyne made changes - 10/Jul/19 02:23 PM
Summary Connection does not see itself in the MON$ATTACHMENTS Connection does not see itself in the MON$ATTACHMENTS when User/Connection Name is more than 13 unicode characters
Sean Leyne made changes - 10/Jul/19 02:24 PM
Summary Connection does not see itself in the MON$ATTACHMENTS when User/Connection Name is more than 13 unicode characters Connection does not see itself in the MON$ATTACHMENTS when Username is longer than 13 unicode characters (31 characters)
Alexander Peshkov made changes - 10/Jul/19 03:36 PM
Assignee Alexander Peshkov [ alexpeshkoff ] Dmitry Yemanov [ dimitr ]
Dmitry Yemanov made changes - 12/Jul/19 08:27 AM
Fix Version/s 3.0.5 [ 10885 ]
Dmitry Yemanov added a comment - 12/Jul/19 08:33 AM
It should be fixed now, please test the next snapshot build, once it's available.

Maxim Kuzmin added a comment - 15/Jul/19 12:37 AM
Dmitry, in area http://web.firebirdsql.org/download/snapshot_builds/win/3.0/ last build #33152 from 7 july.

Dmitry Yemanov added a comment - 15/Jul/19 03:54 PM
It's available now.

Maxim Kuzmin added a comment - 17/Jul/19 03:18 AM - edited
Dmitry, in the snapshot a connection sees itself in the MON$ATTACHMENTS.

Dmitry Yemanov made changes - 17/Jul/19 05:24 AM
Status Open [ 1 ] Resolved [ 5 ]
Fix Version/s 4.0 Beta 2 [ 10888 ]
Resolution Fixed [ 1 ]
Dmitry Yemanov made changes - 17/Jul/19 05:27 AM
Summary Connection does not see itself in the MON$ATTACHMENTS when Username is longer than 13 unicode characters (31 characters) Connection does not see itself in the MON$ATTACHMENTS when Domain/Username (using SSPI) is 31 bytes long
Pavel Zotov made changes - 25/Jul/19 06:20 AM
Status Resolved [ 5 ] Resolved [ 5 ]
Test Details Could not reproduce on 3.0.4 (Windows). Sent letter to alex and dimitr, 25.07.2019 09:18. Waiting for reply.
QA Status No test Deferred
Pavel Zotov made changes - 25/Jul/19 10:40 AM
Status Resolved [ 5 ] Resolved [ 5 ]
Test Details Could not reproduce on 3.0.4 (Windows). Sent letter to alex and dimitr, 25.07.2019 09:18. Waiting for reply.
See notes in .fbt file.
QA Status Deferred Done with caveats
Pavel Zotov made changes - 25/Jul/19 10:41 AM
Status Resolved [ 5 ] Closed [ 6 ]