Issue Details (XML | Word | Printable)

Key: CORE-6170
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: John Franck
Votes: 1
Watchers: 3
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Cannot install on CentOS 8 because version of LibTomMath and LibNCurses library

Created: 24/Oct/19 08:47 AM   Updated: 03/Apr/20 08:40 AM
Component/s: Installation
Affects Version/s: 3.0.4
Fix Version/s: 4.0 Beta 2

Environment: CentOS 8 64bit

QA Status: Cannot be tested


 Description  « Hide
If I try to install FB 3.0.4 I got the next message:

"/opt/firebird/bin/gsec: error while loading shared libraries: libtommath.so.0: cannot open shared object file: No such file or directory

As for CORE-5445 , after creating a symlink named libtommath.so.0 pointing to libtommath.so.1.0.0 this problem was solved, but the next try I got:

"/opt/firebird/bin/gsec: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

I searched and in /usr/lib64 there is a libncurses.so.6, so I created another symlink named libncurses.so.5 that points to libncurses.so.6, this solved the problem.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
John Franck added a comment - 24/Oct/19 08:55 AM
Sorry, I created this issue by cloning CORE-5445 for simplicity, I didn't know this would also clone Fix Version and Assignee (maybe this should'n occur, IMHO), anyway please correct these fields or let me know if I have to file a new issue (and delete this one).

Alexander Peshkov added a comment - 01/Apr/20 03:18 PM
I'm not going to change ncurses version in prebuilt binaries for FB3 - that violates our rules of minor upgrades (binary should install on a system which already ran major FB version without any issues). FB4 starting with beta2 will be built using ncurses6.

What about your issue - I doubt symlink is best solution here, better use backward compatibility package
https://centos.pkgs.org/8/centos-baseos-x86_64/ncurses-compat-libs-6.1-7.20180224.el8.x86_64.rpm.html
prebuilt package for centos8 or build from sources yourself.

John Franck added a comment - 02/Apr/20 06:46 AM
Ok for fixing in FB4 beta 2.

Also thank you for pointing me to install ncurses5 backward compatibility package on CentOS 8. Anyway I'm running FB3.0.4 successfully on a quite busy test machine running CentOS 8 and ncurses6 with the symlink for months now, just to let you know.

Alexander Peshkov added a comment - 02/Apr/20 08:30 AM
That's funny - in theory major version upgrade should mean incompatible API/ABI changes. Are you running on linux server-only or also use utilities, particular isql?

John Franck added a comment - 02/Apr/20 03:55 PM
I've also used isql, although not so much, and also gbak and nbackup.

Alexander Peshkov added a comment - 03/Apr/20 08:40 AM
I asked about isql cause this is the only place where we use readline for fancy command-line editing which in turn uses ncurses. The fact that it works can mean that we use very narrow part of ncurses or.. major part of soname was upgraded without good reasons to do it.