Issue Details (XML | Word | Printable)

Key: CORE-6272
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Alexander Peshkov
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Failed attach to database not traced

Created: 30/Mar/20 03:56 PM   Updated: 08/Apr/20 06:17 AM
Component/s: Engine
Affects Version/s: 4.0 Alpha 1, 4.0 Beta 1
Fix Version/s: 4.0 Beta 2

QA Status: Done with caveats
Test Details:
Currently can be reproduced only when call fbsvcmgr using local protocol, i.e. without "localhost:" prefix (see Alex's note here).



 Description  « Hide
In some cases (for example - file does not exist) attach failure is not reported in trace.

firebird.conf:
Providers = Engine13
ServerMode = Classic

fbtrace.conf:
database
{
        enabled = true
        log_connections = true
}

$ ./fbtracemgr -se service_mgr -sta -conf fbtrace.conf -user sysdba

In other window:

$ ./isql -user sysdba localhost:something # failure reported in trace
$ ./isql -user sysdba nodb # failure not reported in trace (assume nodb does not exist)



 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 07/Apr/20 10:39 AM
Did you start remote (via host:service_mgr with login and password) or system trace (embedded with login SYSDBA)? First case does not work - that's known bug, second works for me with both SS or CS.

Pavel Zotov added a comment - 07/Apr/20 10:44 AM
I always start trace using remote protocol.