Issue Details (XML | Word | Printable)

Key: CORE-6288
Type: Bug Bug
Status: Closed Closed
Resolution: Incomplete
Priority: Blocker Blocker
Assignee: Unassigned
Reporter: Konstantin Belov
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Could not find acceptable ICU Library on Elbrus E2K

Created: 21/Apr/20 03:11 PM   Updated: 22/Apr/20 04:19 AM
Component/s: Build Issues / Porting
Affects Version/s: 4.0 Beta 1
Fix Version/s: None

Environment: Elbrus E2K with lcc

QA Status: Cannot be tested


 Description  « Hide
I am trying to compile Firebird-4.1436-Beta1 on Elbrus E2K. I add e2k to config files and do this:
./confirure --with-builtin-tommath --with-builtin-tomcrypt && make -i

With '-i' because Elbrus lcc crashes when compiles metadata.fbd and exit with error.
So, I ignore this problem. Then when I try to make install I have this message:
Could not find acceptable ICU Library

If try to execute sudo ./gsec -user sysdba -password 0000 -di the message is:
unable to open database
Could not find acceptable ICU Library
u_init() error 4

Elbrus have this list of iculibs:
libicuuc.so.58 (libc6, 64bit), libicuuc.so (libc6, 64bit)
libicutu -/-
libicutest -/-
libicui18n -/-
libicuio -/-
libicudata -/-
all of them in /usr/lib64

My lcc is 1.23.18 and it is compatible with gcc 5.5.0
And there is no errors with Elbrus on x86_64 with gcc 5.5.0.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Mark Rotteveel added a comment - 21/Apr/20 03:20 PM
I think this is a question that is more suitable for the firebird-devel mailing list than for the bug tracker.

Alexander Peshkov added a comment - 21/Apr/20 03:25 PM
Konstantin I close an issue cause tracker is wrong place for discussing new ports. Please use firebird-devel@lists.sourceforge.net (don't forget to subscribe yourself). Also you may ask peshkoff@mail.ru (in russian).