Issue Details (XML | Word | Printable)

Key: CORE-6304
Type: Bug Bug
Status: Closed Closed
Resolution: Won't Fix
Priority: Major Major
Assignee: Unassigned
Reporter: Krzysztof Gałka (DGCS S.A.)
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Cannot run Firebird 3.0.4 and 3.0.5 on Mac OS X 10.10.5 (Yosemite)

Created: 15/May/20 01:23 PM   Updated: 21/May/20 07:45 AM
Component/s: Build Issues / Porting
Affects Version/s: 3.0.4, 3.0.5
Fix Version/s: None

Environment:
Mac OS X 10.10.5 (Yosemite)
iMac (24 inch, Mid 2007)
Processor: 2,4 GHz Intel Core 2 Duo
Memory: 4 GB 667 MHz DDR2 SDRAM

QA Status: No test


 Description  « Hide
Hello,

one of the users of our application is not able to run Firebird 3.0.4 on Mac OS X 10.10.5 (Yosemite).

The firebird.log file contains the following output (repeated):

/Library/Frameworks/Firebird.framework/Resources/bin/fbguard: guardian starting /Library/Frameworks/Firebird.framework/Versions/A/Resources/bin/firebird
/Library/Frameworks/Firebird.framework/Resources/bin/fbguard: /Library/Frameworks/Firebird.framework/Versions/A/Resources/bin/firebird terminated abnormally (-1)

We have also tried Firebird 3.0.5, but it produces the same output. According to https://firebirdsql.org/en/firebird-3-0-4/ Firebird 3.0.4 requires Mac OS X 10.7.

Earlier, there was no similar issue when running Firebird 2.5.

The user cannot update the system because of other software, which does not work correctly on newer version of Mac OS X.

Could the reason be that the package available on the website https://firebirdsql.org/en/firebird-3-0-4/ could have been built with a newer version of Mac OS X?

Kind regards,
Krzysztof Gałka

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 15/May/20 02:50 PM
Why do you report as a bug that firebird does not run on Mac OS less then required according to documentation?

A few words - we can not use too old toolchain to build FB3 for Mac because we use C++ features not supported with ancient toolchains. And a minimum one ok for FB3 does not build binaries for 10 (or more) years old OS. I.e. requirement to have version 10.7 or newer is technically clear. BTW, I doubt that FB3 is able to run on same old linux.

Krzysztof Gałka (DGCS S.A.) added a comment - 18/May/20 08:34 AM - edited
Hello,

thank you for the response.

OS X 10.10.5 (a release of 10.10, not 10.5) is newer than the required 10.7.

From my understanding, it should be possible to run Firebird on that version of OS X?

Could this issue be reopened?

Kind regards,
Krzysztof Gałka