Issue Details (XML | Word | Printable)

Key: CORE-6313
Type: Task Task
Status: Closed Closed
Resolution: Won't Fix
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Basil A. Sidorov
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Linux: Upgrade to libtommath1 (link with libtommath.so.1)

Created: 20/May/20 12:19 PM   Updated: 29/Jul/20 04:15 PM
Component/s: Build Issues / Porting
Affects Version/s: 4.0 Beta 2
Fix Version/s: None


 Description  « Hide
Firebird 4.0 beta 2 uses libncurses6 from base system "newest linuxes" (f.e. - CentOS 8 and Ubuntu19).
"Newest linuxes" also migrate to libtommath1 (libtommath.so.1), but FB40b2 linked with libtommath.so.0.
In coordination need link with libtommath.so.1

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 20/Jul/20 10:14 AM
Appears to be useless change. Firebird 4 currently can be installed on both types of systems with tommath 0 and 1.

Adriano dos Santos Fernandes added a comment - 20/Jul/20 12:09 PM
I think there is a problem really.

Every time I try to install the binaries package in new Ubuntu I have a problem.

Alexander Peshkov added a comment - 21/Jul/20 08:46 PM
@Adriano - do you mean FB3 or FB4 binaries?
Can you try with current fb4 snapshot?


Adriano dos Santos Fernandes added a comment - 29/Jul/20 04:15 PM
Alex, after installing linbcurses5, looks like ok now in Ubuntu 20.04.

However I must say I don't like that our installer creates symlink for libtommath.so.0 in /lib/x86_64-linux-gnu as that system directories changes are generally handled by packages.

If I move this symlink to /opt/firebird/lib things still works. So why not use /opt/firebird/lib?