Issue Details (XML | Word | Printable)

Key: CORE-6348
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: michalk1
Votes: 0
Watchers: 7
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Wire compression causes freezes

Created: 30/Jun/20 11:23 AM   Updated: 28/Jul/20 01:15 PM
Component/s: Engine
Affects Version/s: 4.0 Beta 2, 3.0.6
Fix Version/s: 4.0 RC 1, 3.0.7

Environment: Tested on Win 10 and virtual Ubuntu 20.04 (server side) with 64 bit FB 3.0.6, client app at Win 10.
Issue Links:
Relate
 

QA Status: Done successfully
Test Details:
NB: platform currently is 'Windows' because we have to launch child Python process and pass scenario to be executed with:
FB_CLNT = os.path.join(fb_home, 'fbclient.dll')

This will be fixed later (to make test able to run under POSIX).
Test Specifics: Platform (Windows/Linux) specific


 Description  « Hide
Extracted from CORE-6346, as it is likely an independent issue. Active wire compression causes periodic blocks in FB 3.0.6. I first noticed it when inserting large binary blobs and executing long ddl statements, but probably affects all TCP communication.

The blocks last for up to several minutes, during which there is no obvious server activity (minimum CPU/HDD/Network load), so it looks rather like a timeout. The process eventually resumes (no error message), but the problem repeates soon after (on another blob segment or ddl command).
  
To reproduce the problem, it it sufficient to try to insert a large file (say Firebird installation exe file) into a binary blob field when wire compression is active. In FB 3.0.5 it takes just a second, while in 3.0.6 it would now probably last tens of minutes.

Workaround is either to disable the wire compression or switch back to FB 3.0.5.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Sean Leyne added a comment - 30/Jun/20 03:37 PM
This ticket seems related to other connection issues reported related to 3.0.6 [CORE-6346, CORE-6347 and CORE-6348]

Alexander Peshkov added a comment - 02/Jul/20 11:01 AM
Confirm an issue - reproduced

Alexander Peshkov added a comment - 02/Jul/20 03:33 PM
This freeze is not related with CORE-6346, CORE-6347.
It's a regression caused by CORE-6296.

michalk1 added a comment - 28/Jul/20 06:28 AM
I confirm that the current snapshot build works ok, no more freezes.
Any chance that there will be a release fixing this, sooner than says the current roadmap for 3.0.7 (Q1/2021) ?

Dmitry Yemanov added a comment - 28/Jul/20 01:15 PM
Yes, likely in August.