Issue Details (XML | Word | Printable)

Key: CORE-6396
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Pavel Zotov
Votes: 0
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Unknown tag (0) in isc_svc_query() results

Created: 30/Aug/20 04:47 PM   Updated: 08/Sep/20 07:13 PM
Component/s: None
Affects Version/s: 4.0 Beta 2, 3.0.6
Fix Version/s: 3.0.7, 4.0 RC 1

Issue Links:
Duplicate
 

QA Status: Cannot be tested
Test Details:
First time it was found in LI-V2.5.8.27072 and 2.5.9.27117. Number of attachments did not matter but trace .conf must contain almost all options with include status = true.
Discussed with Vlad and Alex since 13.12.2017; resumed 19.09.2018; 20.11.2018; 23.11.2018 (catched additional debug info, got explanations from Alex); 11.02.2019.

Bug can not be reproduced in normal time: at least 25 minutes required for this, without 100% warranty that this error occurs.


 Description  « Hide
When running trace from fbsvcmgr sometimes (rather rarely) it fails with error message:

Unknown tag (0) in isc_svc_query() results

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Dimitry Sibiryakov added a comment - 31/Aug/20 12:30 PM
Right patch for this ticket:
--- fbsvcmgr.cpp 2020-07-31 16:39:24.451208300 +0200
+++ fbsvcmgr.cpp.new 2020-08-31 14:29:01.833963800 +0200
@@ -969,8 +969,7 @@
                                printf("\n%s\n", getMessage(18).c_str());
                        }
                        fflush(stdout);
- ret = true;
- break;
+ return true;

                case isc_info_svc_timeout:
                case isc_info_data_not_ready: