Issue Details (XML | Word | Printable)

Key: CORE-703
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Trivial Trivial
Assignee: Alexander Peshkov
Reporter: comkeen
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Using DEL-Key in isql under Linux gives "~"

Created: 31/Oct/04 12:00 AM   Updated: 16/Aug/07 02:51 PM
Component/s: ISQL
Affects Version/s: None
Fix Version/s: 2.1 Beta 1

Time Tracking:
Not Specified

SF_ID: 1057695


 Description  « Hide
SFID: 1057695#
Submitted By: comkeen

Hi,
 
I just compiled and set up firebird-1.5.1 (SuperServer)
on my Linux-PC and tried some examples from the
Firebird 1.5 Quick Start Guide. Since I want to learn
some SQL basics, I'm not using any GUI client, but
fiddled around with isql.
 
I noticed that my DELETE-Key doesn't work like it does
in other applications: Instead of deleting the character
at the cursor position, it prints the "~" sign - no matter
whether I use isql on a standard console or an XTerm. I
even tried to emulate different keyboard layouts (with
KDE's "Konsole"): XTerm (XFree 4.x), XTerm (XFree
3.x), vt100, vt420pc - but nothing happened.
 
I don't think that's a "bug", so I decided to open a
Feature Request instead. It would be nice if the
DEL-Key behaves as expected - just a cosmetical topic.
 
Regards,
 Christian

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 05/Apr/07 09:38 AM
Had to upgrade readline version in our tree.
Also added ./configure switch --with-system-readline, making use of library, currently present in OS. If it's not too old, this also fixes a problem.