Issue Details (XML | Word | Printable)

Key: CORE-881
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Adriano dos Santos Fernandes
Reporter: Adriano dos Santos Fernandes
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Singleton isn't respected in COMPUTED BY expressions

Created: 29/Jul/06 04:25 AM   Updated: 12/Nov/07 08:58 PM
Component/s: Engine
Affects Version/s: 2.0 RC3, 2.0.1, 2.0.2, 2.0.3
Fix Version/s: 2.1 Alpha 1, 2.0.4

Time Tracking:
Not Specified

Issue Links:
Relate
 


 Description  « Hide
Problem is caused by not complete "copy" of nod_rse in cmp.cpp.
It may occur in others conditions (not with COMPUTED BY), but it's reproducable with it.

create table t1 (n integer);
create table t2 (n integer, c computed by ((select n from t1)));

insert into t1 values (1);
insert into t1 values (2);

insert into t2 values (1);

-- this select should throw a error since the computed expression returns more than one row
select * from t2;


 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Pavel Cisar added a comment - 21/Apr/07 01:48 PM
Fix confirmed for 2.1 Alpha 1. Test added.

Pavel Cisar added a comment - 26/Apr/07 11:41 AM
Reopened to update ticket information.