Issue Details (XML | Word | Printable)

Key: CORE-968
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Critical Critical
Assignee: Alexander Peshkov
Reporter: S?bastien DEJEAN
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Lost Connection with Firebird Server

Created: 23/Oct/06 09:49 AM   Updated: 16/Jun/07 10:05 AM
Component/s: Engine
Affects Version/s: 2.0 RC5
Fix Version/s: 2.1 Alpha 1, 2.0.2

Time Tracking:
Not Specified

Environment:
Server : Linux Ubuntu 6.10 Edgy
Client : Windows XP SP2
Firebird 2.0 RC5 (compiled form cvs source)


 Description  « Hide
It happens during both the GBAK resore process directly on the server (so no network connection, just a localhost network connection) and a when executing long query or long procedure (on my client)
For example on a 400000 records table, i launch en update on all records, but i always get a :

Unable to complete network request to host "IP address".
Error reading data from the connection.

I get a similar error while inserting many records:

Unable to complete network request to host "IP address".
Error writing data to the connection.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Dmitry Yemanov added a comment - 23/Oct/06 09:57 AM
What's in firebird.log?

S?bastien DEJEAN added a comment - 23/Oct/06 12:08 PM
on flamerobin i've got :

Starting transaction...
Preparing query: EXECUTE PROCEDURE UPDATE_CA_KEYS
Prepare time: 00:00:00.
Plan not available.


Executing...
*** IBPP::SQLException ***
Context: Statement::Execute( EXECUTE PROCEDURE UPDATE_CA_KEYS )
Message: isc_dsql_execute2 failed

SQL Message : -902
Unsuccessful execution caused by a system error that precludes
successful execution of subsequent statements

Engine Code : 335544721
Engine Message :
Unable to complete network request to host "IP address".
Error reading data from the connection.


Execute time: 00:05:32.

if firebird.log :

arthur (Server) Tue Oct 24 18:59:52 2006
        GDS Assertion failure: ../src/jrd/os/posix/isc_ipc.cpp 207
arthur (Client) Tue Oct 24 18:59:52 2006
        /opt/firebird2/bin/fbguard: bin/fbserver terminated abnormally (-1)
arthur (Client) Tue Oct 24 18:59:52 2006
        /opt/firebird2/bin/fbguard: guardian starting bin/fbserver
arthur (Client) Tue Oct 24 18:59:52 2006
        /opt/firebird2/bin/fbguard: guardian could not open /var/run/firebird/S14firebird.pid for writing, error 2

S?bastien DEJEAN added a comment - 15/Nov/06 05:02 PM
I test the 2.0 final release and i have the same problem.
does anyone have this same issue ?
thanks

Alexander Peshkov added a comment - 01/Dec/06 04:19 AM
In log I see:
arthur (Server) Tue Oct 24 18:59:52 2006
        GDS Assertion failure: ../src/jrd/os/posix/isc_ipc.cpp 207

It means you use DEBUG version of server, not release. DEBUG builds are not supposed to be used in production. They are used by developers to fix some specific issues with firebird. They are MUCH slower compared with production builds (10 times will be a good estimation). In many cases when release tries to recover in any way, debug asserts. Be sure this is not what you need working with real database.

On the other hand, assertion that I see in the log is certainly not good thing. At the first look at source code I have not found a place where it might happen. On the other hand, technic used to make calls to ISC_inhibit() / ISC_enable() match is 'slightly' old and shoudl be replaced with newer one.
And it will be very interesting to have a look at backtrace of core, created when assertion in isc_ipc took place.

Alexander Peshkov added a comment - 22/Feb/07 12:02 PM
Added classes automatically making calls to inhibit/enable match.

Pavel Cisar added a comment - 15/Apr/07 11:16 AM
When this issue was classified as critical, shouldn't we backport it into 2.0.x ? It was reported on 2.0 RC5, so it's strange it slipped the 2.0.1 maintenance. You should either downgrade it from critical or schedule the fix also for 2.0.2.

Alexander Peshkov added a comment - 17/Apr/07 04:56 AM
backported to 2_0_Release

Dmitry Yemanov added a comment - 26/Apr/07 09:23 AM
Re-opened just to update the ticket information.