Issue Details (XML | Word | Printable)

Key: CORE-981
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Minor Minor
Assignee: Alexander Peshkov
Reporter: Rick Wagner
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

x86_64 RPM package missing "provides"

Created: 29/Oct/06 12:47 PM   Updated: 16/Jun/07 10:18 AM
Component/s: Build Issues / Porting
Affects Version/s: 2.0 RC5
Fix Version/s: 2.1 Beta 1

Time Tracking:
Not Specified

Environment: Fedora Core 5, x86_64


 Description  « Hide
I installed FirebirdSS-2.0.0.12745-ReleaseCandidate5.amd64.rpm on Fedora Core 5, x86_64. This package supplies the following to the RPM system (rpm --query --provides FirebirdSS):

libfbclient.so.2
libgds.so
FirebirdSS = 2.0.0.12745-ReleaseCandidate5


I can build various other packages with Firbird support (PHP, qt, hk_classes), and they build fine. However they fail to install, due to the missing dependency "libfbclient.so.2()(64bit)". Thus when I build the binary for "hk_classes" (http://hk-classes.sourceforge.net/, .spec file from http://svn.rpmforge.net/svn/trunk/rpms/hk_classes/hk_classes.spec), the binary build fine. Attempting to install the binary package:

# rpm -ivh /home/rwagner/rpmbuild/RPMS/x86_64/hk_classes-0.8.2-0rw1.x86_64.rpm
error: Failed dependencies:
        libfbclient.so.2()(64bit) is needed by hk_classes-0.8.2-0rw1.x86_64
#

This can be worked around by using the "AutoReqProv: no" in the package definition of the client .spec file.

I've seen this attempting to build php and qt too.


Another suggestion, have the package supply a generic "Firebird" or "FirebirdSQL". That way clients can use a generic 'Requires' clause; the clients should have to know whether the Firebird server is SS or CS. Yet I have to build the clients with a specific "Requires" clause of either FirebirdSS or FirbirdCS.


 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 25/Apr/07 09:51 AM
Rick, would you be able to test packages when I do changes?
I do not have access to rpm-enabled 64-bit linux.

Rick Wagner added a comment - 26/Apr/07 02:44 AM
Alexander,

Yes I can test a package. Both FC6 and FC5, if that matters.

Thanks,
  --rick

Philippe Makowski added a comment - 26/Apr/07 03:13 AM
can't we provide a package with libfbclient only ?
under Mandriva it is what is done

%package -n %libfbclient
Summary: Multi-threaded, non-local client libraries for Firebird SQL Database
Group: System/Libraries

%description -n %libfbclient
Multi-threaded, non-local client libraries for Firebird SQL Database

%files -n %libfbclient
%defattr(0644,root,root,0755)
%dir %{fbroot}/lib
%{_libdir}/libfbclient.so.*
%{fbroot}/lib/libfbclient.so.*


Rick Wagner added a comment - 12/May/07 03:04 PM
Alexander,

I installed the package. During installation I got the following messages:

Starting Firebird server: ASSERT: file ../src/utilities/ibmgr/ibmgr.cpp line 711: in_sw = 20
server has been successfully started

I then rebuilt PHP, removing the "AutoReqDep: No" line. Installing the updated PHP worked.

This package seems to have fixed the problem!

Thank you.

Alexander Peshkov added a comment - 14/May/07 09:55 PM
Learned rpmheader to distinguish between 32/64 builds.
Also fixed reported by Rick assertion in fbmgr when DEV_BUILD.