Issue Details (XML | Word | Printable)

Key: DNET-192
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Jiri Cincura
Reporter: Jiri Cincura
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
.NET Data provider

The ServerVersion property returns wrong version

Created: 19/Oct/08 05:18 PM   Updated: 07/Feb/09 11:58 AM
Component/s: ADO.NET Provider
Affects Version/s: 2.5.0 Alpha 2
Fix Version/s: 2.5.0 Beta 1

Issue Links:
Relate
 


 Description  « Hide
The call is for isc_info_isc_version, but it should be isc_info_firebird_version.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Carlos Guzman Alvarez added a comment - 19/Oct/08 06:02 PM
While that maybe not a real proble, check if that change will work against Interbase ( at least against the v6.0 )

Jiri Cincura added a comment - 19/Oct/08 06:13 PM - edited
The problem is, that isc_info_isc_version is in FB hardcoded (major and minor number). I think, that isc_info_firebird_version will defintely not work on IB. But it's not problem - if somebody needs it on IB (and not using IB's provider), (s)he can use FbDatabaseInfo.IscVersion (and because we're no longer IB, it's acceptable IMO).