Issue Details (XML | Word | Printable)

Key: DNET-550
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Major Major
Assignee: Jiri Cincura
Reporter: Hennadii Zabula
Votes: 1
Watchers: 1

If you were logged in you would be able to see more operations.
.NET Data provider

NotSupportedException occurs when using ServerType embedded

Created: 03/Apr/14 07:21 AM   Updated: 26/Aug/15 07:56 AM
Component/s: None
Affects Version/s:
Fix Version/s: None

File Attachments: 1. Zip Archive (17 kB)

 Description  « Hide
Exception throwed from Common.DbValue.GetBytes
public byte[] GetBytes()
switch (this.Field.DbDataType)
default: throw new NotSupportedException("Unknown data type");

with this.Field.DbDataType equal to DbDataType.Null

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Hennadii Zabula added a comment - 03/Apr/14 07:39 AM
Fix is provided here.
I have complications to make the pull request for just only this one commit

Jiri Cincura added a comment - 03/Apr/14 10:15 AM
Provide a test-case.

Hennadii Zabula added a comment - 04/Apr/14 05:19 AM - edited
Added minimal solution, which reproduces the problem
Solution consist of
- Model: DatabaseContext + Entities
- Model.Test: One query that reproduces the issue.
If change ServerType to Remote in app.config, exception would not throw.

Jiri Cincura added a comment - 26/Aug/15 07:56 AM
I'm unable to reproduce the error with