Issue Details (XML | Word | Printable)

Key: DNET-705
Type: Bug Bug
Status: Closed Closed
Resolution: Duplicate
Priority: Major Major
Assignee: Jiri Cincura
Reporter: Ralf Jansen
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
.NET Data provider

FBStatistical does not like pathes to database with non ascii characters in it

Created: 05/Oct/16 02:01 PM   Updated: 14/Jul/17 02:17 PM
Component/s: ADO.NET Provider
Affects Version/s: 5.0.5.0, 5.5.0.0
Fix Version/s: None

Environment: Windows 10 (de locale), Visual Studio 2015, Firebird Embedded 2.5.6 and 3.0.1
Issue Links:
Relate
 


 Description  « Hide
Trying to use FBStatistical against a database residing in a path with non-ascii characters (like german umlauts) fails with a Exception that the database can't be opened

Sample

   FbStatistical stat = new FbStatistical();
   stat.ConnectionString = "server type=Embedded;character set=UTF8;initial catalog=C:\MyLovelyFolder\aö\database.fdb;user id=SYSDBA;password=masterkey;pooling=False;client library=C:\Firebird_x64\fbembed.dll"
   stat.Options = FbStatisticalFlags.HeaderPages;
   try
   {
       stat.Execute();
   }
   catch (FbException ex)
   {
       ....
   }

will result in an "Can't open database file C:\\MYLOVELYFOLDER\\Aö\\DATABASE.FDB" with ErrorCode 336920605 Exception.
Interesting sidenote the internal uppercasing ignored the ö umlaut.




 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Ralf Jansen added a comment - 10/Oct/16 04:12 PM - edited
I work around that problem currently with changing the path into a shortpath and hope that it will not create other problems.

Ralf Jansen added a comment - 14/Oct/16 01:48 PM
Unfortunately using the shortpath is no workaround :( Shortpath handling can be deactivated in windows and seems to be the default in current windows versions that 8.3 format is deactivated for non-system partitions.
Can someone confirm that using non ascii characters in database pathes does not work with anything that uses the service API (via FBService)?

Ralf Jansen added a comment - 24/Oct/16 11:43 AM
Moved to Provider version 5.5 and can only replicate the problem with FB3. FB2.5 seems ok.

Problem might be correlated CORE 5154 anf therefore be a engine thing and not a provider thing even if CORE-5154 is marked as fixed.


Jiri Cincura added a comment - 14/Jul/17 06:42 AM
Is this still happening? On FB3.0.2 say.

Ralf Jansen added a comment - 14/Jul/17 10:38 AM
Just checked firebird embedded versions 3.0.2.32615 and 3.03.32749 (i don't t have the official 3.0.2 build at hand) using provider 5.5.0.0
Both fail as described above.


Jiri Cincura added a comment - 14/Jul/17 11:34 AM
OK, this is actually a duplicate of DNET-772, I think.

Ralf Jansen added a comment - 14/Jul/17 01:58 PM
If i recall correctly i tried throwing isc_dpb_utf8_filename also into the ServiceParameterBuffer back then but with no effect. So i was under the impression that there is an underlying problem in firebird itself and not or not only in the provider.

Jiri Cincura added a comment - 14/Jul/17 02:17 PM
I needs to be isc_spb_utf8_filename, because it's service_mgr. I think that will make it work fine.