Issue Details (XML | Word | Printable)

Key: DNET-743
Type: Bug Bug
Status: Closed Closed
Resolution: Won't Fix
Priority: Major Major
Assignee: Jiri Cincura
Reporter: Alexander Lipatov
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
.NET Data provider

Memory leak in Firebird 3 on implicit transaction

Created: 22/Mar/17 12:58 PM   Updated: 05/Apr/17 06:58 AM
Component/s: ADO.NET Provider
Affects Version/s: 5.8.0.0
Fix Version/s: None

Environment: Firebird: 3.0.1.32609, .NET Provider: 5.8, .NET 4.6, Win 10 x64
Issue Links:
Depend
 


 Description  « Hide
Implicit transactions in Firebird 3 cause a massive memory leak on the server part.
It is detected only on Firebird 3.
If transaction is performed manually the memory leak is not happened.

Example:
var connection = new FbConnection(connectionString);
connection.Open();
while (true)
{
    using (var cmd = connection.CreateCommand())
    {
        cmd.CommandText = "SELECT * FROM TABLE_NAME";
        cmd.ExecuteNonQuery();
    }
}

I fixed this issue as follows:
The calls isc_commit_transaction and isc_dsql_free_statement was swapped.


 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Jiri Cincura added a comment - 05/Apr/17 06:58 AM
This behavior is caused by CORE-5416.