Issue Details (XML | Word | Printable)

Key: DNET-817
Type: Bug Bug
Status: Closed Closed
Resolution: Duplicate
Priority: Major Major
Assignee: Jiri Cincura
Reporter: Peter Barbanyaga
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
.NET Data provider

Big model (Code first Entity Framework) and Firebird 3.0

Created: 10/May/18 07:58 AM   Updated: 10/May/18 08:14 AM
Component/s: ADO.NET Provider
Affects Version/s: 5.12.1.0
Fix Version/s: None

Environment: Firebird 3.0, FirebirdClient 5.12.1.0, Entity Framework 6.2
Issue Links:
Duplicate
 


 Description  « Hide
We try to use the approach of Code First (Entity Framework 6.2) with the DBMS Firebird 3.0. For a small model (up to 10 tables) migrations are generated and executed.
The problem arises when there is a large model (in our case 153 tables) - in this case we are faced with a "limit on the maximum length of a BINARY type" (because full EF-model (Code first) is written in the field 'Model'):

FirebirdSql.Data.FirebirdClient.FbException (0x80004005):
Dynamic SQL Error Dynamic SQL Error SQL error code = -104
String literal with 66866 characters exceeds the maximum length of 65535 characters for the BINARY character set


Related issue: http://tracker.firebirdsql.org/browse/CORE-5821

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Mark Rotteveel added a comment - 10/May/18 08:11 AM
This is probably a duplicate of DNET-769